Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a crash, something I did I'm sure, and installed Ubuntu 11.10 from a thumb drive.

I then upgraded to 12.04 basically immediately.

From there I found my wireless not working. So following some instructions in Ask Ubuntu I tried to get it working. Currently it said I needed to do a sudo dpkg command, I did, and now it is stalled at DKMS: install completed.

DKMS: uninstall completed.

------------------------------
Deleting module version: 6.20.155.1+bdcom
completely from the DKMS tree.
------------------------------
Done.
Loading new bcmwl-6.20.155.1+bdcom DKMS files...
Building only for 3.2.0-38-generic
Building for architecture i686
Building initial module for 3.2.0-38-generic
Done.

wl:
 Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-38-generic/updates/dkms/

depmod....

DKMS: install completed.

I hit Ctrl + C and this came up:

Setting up build-essential (11.5ubuntu2.1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-38-generic
Errors were encountered while processing:
 bcmwl-kernel-source

So now what? I apparently need to rebuild the kernel? And wireless is still not available until I do.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.