Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After release of ubuntu 12.04.2 I tried update my system with:

sudo apt-get install linux-generic-lts-quantal xserver-xorg-lts-quantal

unfortunately after that my network was not working. It just started infinity reconnection loop. With something like this in syslog:

device state change: unavailable -> disconnected (reason 'carrier-changed')

Looks like problem in new e1000e kernel embedded driver because when i downgrade to 3.2.0-38 all worked fine.

My hardware is thinkpad x230 with core i7.

lspci -v

00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
    Subsystem: Lenovo Device 21f3
    Flags: bus master, fast devsel, latency 0, IRQ 42
    Memory at f2500000 (32-bit, non-prefetchable) [size=128K]
    Memory at f253b000 (32-bit, non-prefetchable) [size=4K]
    I/O ports at 5080 [size=32]
    Capabilities: <access denied>
    Kernel driver in use: e1000e
    Kernel modules: e1000e

Now i work with older kernel. But i have good reproduction of this problem and i can provide any needed additional info. So maybe i can help solve this issues but i have no ideas how.

share|improve this question
I'd be very surprised if the standard 10.10 kernel would work without problems in a 12.04 system. –  guntbert Feb 24 '13 at 21:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.