Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have seen the following question, however it doesn't solve my problem:

I can't update my Ubuntu 12.04! I get the following error after running sudo apt-get update:

E:GPG error: http://http precise/ Release: The following signatures were invalid: NODATA 1 NODATA 2

Following is the content of /etc/apt/sources.list:

###### Ubuntu Main Repos
deb http://mirror.informatik.uni-mannheim.de/pub/linux/distributions/ubuntu/ pr$
deb-src http://mirror.informatik.uni-mannheim.de/pub/linux/distributions/ubuntu$
3rd Party Binary Repos
#### Google Chrome Browser - http://www.google.com/linuxrepositories/
## Run this command: wget -q https://dl-ssl.google.com/linux/linux_signing_key.$
deb http://dl.google.com/linux/chrome/deb/ stable main

What I have tried so far:

  • I have tried changing sources and made a new, clean /etc/apt/sources.list file. But the issue still persists.
  • Running sudo rm /var/lib/apt/lists/* -vf doesn't help either.

How do I resolve the issue?

share|improve this question
    
post the contents of /etc/apt/sources.list –  bodhi.zazen Feb 19 '13 at 18:07
    
Are you still experiencing this problem? Nothing here points to any differences between this and that question, but if none of the solutions there helped, then this should of course be investigated further. Does the error message actually say http://http precise/? That's not a valid URL. If not, what does it say? If so, what's the contents of /etc/apt/sources.list (i.e., the output of cat /etc/apt/sources.list), as @bodhi.zazen requested. (You can edit your question to provide large blocks of text.) –  Eliah Kagan Apr 13 '13 at 6:38
add comment

marked as duplicate by Eliah Kagan, jokerdino Apr 13 '13 at 6:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

I had the same problem. I don't want to sound silly but I found it was my network connection. I am at an office where we have tight internet security on on wired LAN. I have been working on this for 3 days now. As soon as I switched to our open public wireless, I was able to run the clean and update without any problems. I hope it's that easy for you as well.

FWIW: I'm running Zorin Linux with 3.5.0-23 kernel on 64bit

share|improve this answer
    
I had the same problem, as I lock down my home Internet by using OPENDNS. I bypassed it by changing my DNS settings in /etc/resolv.conf –  Andrew Neely Sep 6 '13 at 22:37
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.