Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Ubuntu 12.10 on a Supermicro storage server and have an issue.

I am using alternate (text-based) installation cd image and when I get to the Detect disks section it says there is a s/w raid on the device and asks me whether I want to activate it.

enter image description here

I select no and proceed to manual partitioning. There I create a new partition table on the target device, create partitions and so on, but when I select write changes to disk it gives an error that it is not able to format /dev/sda1 (root).

enter image description here

I tend to think that it has something to do with that s/w raid I don't even have! From the current system (Debian Etch) I have searched for that array, but have not found any.
cat /proc/mdstat - nothing
mdadm -As - no arrays found
cat /etc/mdadm/mdadm.conf - no arrays there
mdadm -E /dev/sda; mdadm -E /dev/sda1 - nothing

The reason I'm talking about this raid array is because there was some other system I was not able to install Ubuntu on that also detected some array. I can't remember exactly, but on that former system there actually might have been some s/w raid, but I was not able to remove it whatever I did: clear superblock, may be even dd.

Edit 1

So, I've managed to get rid of ATA RAID. I knew forehand that there was no h/w raid on the server, but as it turned out it has a fakeRAID/hostRAID (not Linux s/w raid as I thought previously). Here is what I've done in my case (for reference purposes):

  1. Tried to delete the array using BIOS-level utility for RAID management, but to no avail, since it didn't find any arrays already present.
  2. Wipe out metadata from the drives using current OS installation and with Execute a shell section during Ubuntu installation: dmraid -r -E. That resulted in errors and failed to delete metadata.
  3. Finally, I ended up with clearing the first and last GBs of each drives with dd:
    dd if=/dev/zero of=/dev/sdb bs=1GB count=1
    dd if=/dev/zero of=/dev/sdb bs=1GB seek=999 (1 TB drive)

I thought I'd be good now, but no! As I've mentioned it does not detect any raid arrays anymore, but I still cannot format the partition.

I'm using a fromLinux approach to installation, where I have hd-media files: vmlinuz and initrd.gz to boot with and an installation iso. I'm installing to sda, have the iso on sdb and tried to put the above 2 files to either sda or sdb, though I think it doesn't matter after they are loaded into RAM. Regardless though of the drive I start the installation from - sda or sdb, I can create partitions on sd[bc], but not sda.

Edit 2

This time I have tried to install Ubuntu on a pre-partitioned drive with existing empty filesystems, meaning a have chosen keep existing data at Partition disk section (indicated with K flag).

enter image description here

Everything seems to be fine. It informs me that system directories on unformatted root will be deleted and such, but at the final step it says that it fails to remove existing data, even though there is no data there (it is a clean partition)!

enter image description here

It seems as if the drive was read-only or busy. When I try to format it with mkfs.ext3 /dev/sda using command prompt available during installation it says:

/dev/sda2 is apparently in use by the system; will not make a filesystem there.

Any ideas, Please?

share|improve this question

See if there's an option in your system's BIOS to turn the hostRAID functionality OFF. You could then simply use the SATA controller instead of the hostRAID controller. I've not seen a machine yet that doesn't have that option.

Another option is to reset the BIOS to defaults.

In addition, look for BIOS updates.

share|improve this answer
Thanks for your answer. I have not found the ability to control hostRAID from BIOS, however there is one other utility that can be invoked via keyboard combination (Ctrl+C) before any OS starts. I can completely manage hostRAID with it, but it did not show up any existing arrays. In fact I'm not sure whether the raid was an issue, because it can be assembled on JBOD drives that are in SAS enclosure, while I'm trying to install the system on a single internal SSD drive, which is SATA (currently in IDE mode). May be it has to something to do with the fact that it is SSD? – Pavel A Feb 21 '13 at 12:42
Anyways I seem to have wiped out all the metadata leftovers, so it doesn't detect any hostRAID arrays anymore (see Edit 1), so I assume the raid is not an obstacle anymore. Drives are independent now (no metadata, no info in that utility about current arrays), aren't they? – Pavel A Feb 21 '13 at 12:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.