Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I give up, I've been reading forums all day and most of the stuff I've tried has led to a blank screen after logging in after reboot (No menus) which I've fixed by re-installing as I found it fastest as it was a fresh install anyways :P

My laptop is a Samsung NP-RV520-S02SE with a Nvidia GT 520M graphics card.

As you probably understand I'm fairly new to Ubuntu. I've also tried downloading the .run file from nvidia.com/drivers which gives me some error after loading for a while or I might be opening it wrong.

Any kind soul could help me out getting my drivers installed properly?

share|improve this question
    
have you tried installing the driver from Nvidias site or directly from "Additional drivers" in Ubuntu?. Also: which version of Ubuntu are you running? –  phipsalabim Feb 19 '13 at 15:42
    
This is what I get totte@Totte-Ubuntu:~$ lspci | grep VGA 01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520M] (rev a1) –  Totte Feb 19 '13 at 15:58
    
Forgot to mention that I'm using Ubuntu 12.10 and yes, I've tried installing from Nvidias site. Haven't tried "Additional drivers", not sure which one to chose. –  Totte Feb 19 '13 at 21:19
add comment

marked as duplicate by Web-E, Minato Namikaze, hhlp, Javier Rivera, LnxSlck Feb 20 '13 at 17:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

DON'T EVER INSTALL DRIVERS DIRECTLY FROM NVIDIA OR AMD

I will assume you didn't install anything. In the terminal run:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update

If your card is NOT Optimus enabled run:

sudo apt-get install nvidia-313 nvidia-settings

reboot


If your card IS Optimus enabled run:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

reboot

share|improve this answer
    
No I did not install anything, simply fresh install. That give me weird resolution again, where I can't see any menus or anything :/ Then is said "Graphics: VESA somethingsomething" in the Details thing. It asked me to update, so I did, then rebooted and the resolution went back to normal but now it says "Graphics: Unknown" again :P –  Totte Feb 19 '13 at 23:05
    
Though stuff as the Dashboard menu feels way faster now.. ;o –  Totte Feb 19 '13 at 23:12
    
In terminal run: sudo nvidia-xconfig logout and back in (or possibly reboot... not sure) –  phipsalabim Feb 19 '13 at 23:13
    
So I did, said some file didn't exist so it created it, then I rebooted. Not sure what that did though :P –  Totte Feb 19 '13 at 23:28
    
After you created the empty xorg.conf file did you run sudo nvidia-xconfig again? The "Graphics Unknown" thing in "System Settings > Details" is a harmless bug. You can fix it by running sudo apt-get install mesa-utils. Other than that is everything running ok? –  phipsalabim Feb 19 '13 at 23:41
show 4 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.