Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Dell laptop
Model: N5110 (Inspiron 15R)
Display: 15.6"
Battery: 6 cell
Graphics: NVidia GeForce 525M 1GB (No driver for Ubuntu), Working on Intel Graphics 1GB
OS: Ubuntu 12.04 (Precise) 64 bit

Dell laptop battery backup 1.30 hours only with Ubuntu 12.04. How can the battery backup be increased?

share|improve this question
up vote 1 down vote accepted

I had the same problem and the reason turned out to be that the graphic card was always ON.

What you need to do is to install bumblebee which turns off your graphic card. You can still use it when you need.

Installing Bumblebee

  • Open a terminal (Ctrl+Alt+T).
  • Run the following commands:
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic
  • Reboot or re-login.

For more information, you can visit the Ubuntu BumbleBee Wiki Page.

share|improve this answer

Try the jupiter applet, play around with some settings and see if it helps

Press Ctrl-Alt-t, terminal will pop up; type

sudo add-apt-repository ppa:webupd8team/jupiter

enter password (you won't see it as you type, that's normal), confirm adding the repo, then:

sudo apt-get update && sudo apt-get install jupiter
sudo jupiter

click the "lightning bolt" that appears on the panel, play around with some settings, ie set Performance to "Power on demand" or "Power saving". Reboot.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.