Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The title pretty much says it. I attempted to download steam from the Software Centre, but it gave me an error (something along the lines of "Cannot reach source:", I didn't write it down). I tried reconnecting, but that didn't work. When I restarted the software centre, the entry for Steam (64-bit) had vanished. I checked the web page for Steam 64-bit in the apps repository, but I got a page not found error. Thoughts?

share|improve this question

As per the official repository of steam for Ubuntu, it is available only for precise (Ubuntu 12.04). However, you can still download the .deb file.

share|improve this answer

Steam is in the 'Canonical Partners' repository in 12.10 x86_64. You will need to go to the software center and 'edit' 'Software Sources' and under 'Other Software' tick the 'Canonical Partners'.

[update] New install of Ubuntu today and could not get steam to show, but after logging in to Ubuntu ONE account (click the 'recommended for you' link in software center) and steam now shows up. [/update]

share|improve this answer
I don't think it is; I have partner enabled and it's not available. I did install Steam (64 bit) from the Software Centre, but purged it this morning. It's nowhere to be found now. I've tried partner and multiverse. – Gavin Panella Feb 27 '13 at 11:45
Try logging in with your Ubuntu ONE account. worked for me on a fresh install today. – BaDboD Mar 5 '13 at 9:56
Gavin - Looks like your right, though this did work for me only a week ago, however.... goto /etc/apt/sources.list.d and delete any files with steam in the file name, then do sudo apt-get update. This worked for me on a machine where Steam had previously been installed but had vanished from software center. – BaDboD Mar 5 '13 at 10:32

I was looking for a 64 bit installer because it stop working after an update. And it said something that libsdl2 was missing, or something that I was on low disk space.

I did: rm -r .local/share/Steam Then when I started again steam, it asked me to reinstall it.

It worked fine!

I was trying to install and reinstall the .deb, but it didn't help. Maybe it was some issue with my 64bit 12.10 and update from beta. Now with stable version everything works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.