Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.10. My internet connection was working fine. I tried to connect college LAN after changing IP but it didn't work. Then I changed to previous IP and tried with to connect but now it is showing Connection established but there is no internet access. Output of ifconfig is not having wlan and eth1 is showing interrupt17.

$ ifconfig
eth1      Link encap:Ethernet  HWaddr 00:26:22:c8:2d:2a  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::226:22ff:fec8:2d2a/64 Scope:Link
          RX packets:5551 errors:0 dropped:0 overruns:0 frame:0
          TX packets:232 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:542393 (542.3 KB)  TX bytes:46828 (46.8 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:912 errors:0 dropped:0 overruns:0 frame:0
          TX packets:912 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:64128 (64.1 KB)  TX bytes:64128 (64.1 KB)

What can I do to get this working?

share|improve this question
If your college uses dynamic addressing(that is how it usually is), changing your IP address manually is not advisable. Did you add or remove any other setting recently before your internet connection broke? And don't worry about wlan, its your wireless, you need to enable it using the switch on your keyboard to enable it. – i08in Feb 19 '13 at 9:41
It seems your output is very standard. As @Jobin suggested if it is dynamic address then you should not configured it manually. But since it was working previously it may static ip. Then you should also take care that other people are not using same ip address. In any case I think your college network administrator is the best person to help you in this situation. – Apurba Feb 19 '13 at 10:19

Press Ctrl+Alt+T and then enter this in the command prompt :

echo on | sudo tee /sys/class/net/eth0/device/power/control

After that, unplug your ethernet cable and then plug it in again. It should connect... :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.