Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dusty room, so I decided to use compressed air to remove the dust from throughout my computer, including my graphics card. I used the compressed air to clear out my graphics card then put it back in. When I booted, right away I noticed the grub menu looked strange because the font looked 4x larger. (This happens when I have my dvi cable plugged into the wrong dvi port, but it doesn't matter anymore.)

When I tried to boot Ubuntu I would get a purple screen for a long time followed by a black screen... then nothing. After googling around on another computer I found that adding the "nomodeset" parameter to the grub boot options got me through to the log in. I am able to log in and use the computer, but now I have strange artifacting across the top of my screen and by cursor flickers.

I figured I had damaged my graphics card, except I am able to boot into Windows fine and run video games and graphics card tests. An interesting thing to note is the nvidia driver crashed when I started Windows the first time after cleaning, but was fine after that. This is very strange to me, because the bugs seemed like a hardware error. I tried removing the graphics card and placing it back in, but that doesn't seem to help at all.

So far I have tried:

  • Taking gfx card out then back in
  • Updating UEFI
  • Resetting CMOS
  • Booting from thumb drive Ubuntu (same issue)
  • Changing PCI slot of gfx card
  • Cleaning gfx card connectors with alcohol and swab.

I am using a Asrock Z77 Extreme4 motherboard with a Nvidia 670 gtx graphics card. Any help is welcome.

UPDATE: I bought a nvidia 210 graphics card and swapped it out for my current card. I get the exact same issues with a different nvidia card. I'm not sure if I want to try another brand's card. I am starting to wonder if this could be on the motherboard.

I tried to boot into a Fedora live USB, but get a blank screen, which is what I get on Ubuntu unless I boot with nomodeset.

share|improve this question
    
Since it's not mentioned in your list of stuff you've tried doing, have you tried reinstalling the GPU drivers? –  oaskamay Mar 2 '13 at 5:23
    
Did you try to connect your PC with a VGA or HDMI cable to the monitor? –  Alex Mar 10 '13 at 1:51
    
Yes, this does sound like a hardware issue. It's possible the fan has been damaged and is causing the card to overheat. In the past, I've damaged some fans by "revving" them with canned air. Can you hear the fan? With the case open and on it's side, can you see the blades moving? Do you have any NVIDIA tools that report the GPU temperature and/or fan speed? –  Ramón Mar 10 '13 at 22:03
    
@Ramón I ran OC Scanner stress tests while booted into Windows. The card stayed at normal temperatures and there were no artifacts or errors. –  Paul Mar 11 '13 at 20:36
    
I guess, you can try cleaning the whole video card with alcohol (keeping it in angle and pooring some alchohol) and wait until evapourates completely, and also rubbing the connector with an rubber eraser –  jet Mar 13 '13 at 17:38

2 Answers 2

Can you see into the fins of the heat sink and if so are they for sure clear of dust. You may have to take the heat sink apart to get it completely clean. Only attempt this if you know what you are doing, and have thermal paste handy. This is of course if it is overheating. Try booting into ubuntu from a live cd and see if the problem is still there.

share|improve this answer
up vote 0 down vote accepted

I was able to resolve my problem. It turns out the EDID that my monitor was returning was corrupt. I was able to resolve my issue by power cycling my monitor (among other things).

My monitor is the last place I would expect corruptible state!

The steps I took were:

  • Run tool "get-edid". Tool, reported "Call failure" for one of the EDID blocks.
  • Power cycle monitor
  • Run tool "get-edid". No more failures reported, "Call successful" reported for all blocks.
  • Run nvidia-xconfig (now able to detect proper settings)
  • Restart
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.