Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been a testing 13.04 the new Ubuntu desktop and love it. Before now I have only ever had minor errors but today I tried to install the SDK from ubuntu.

I followed the 2 steps (installing from Terminal) and I got the following error:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 qtmultimedia5-dev : Hängt ab von: libqt5multimediaquick-p5 (= 5.0.1-0ubuntu1) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

which translates to

The following packages have unmet dependencies: qtmultimedia5-dev: Depends: libqt5multimediaquick-p5 (= 5.0.1-0ubuntu1) but it should not be installed
E: Unmet dependencies. Try 'apt-get-f install. "Without specifying a package (or specify a solution)

Its in german (I live in germany but from UK) but basically its referring to a missing dependency however the dependencies wont install.

I tried the following command to fix dependencies:

sudo apt-get -f install

But got the following:

dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb (--unpack):
 Versuch, »/usr/lib/i386-linux-gnu/libQt5MultimediaQuick_p.so.5.0« zu überschreiben, welches auch in Paket libqt5multimediaquick5 5.0.0-0ubuntu1~test2 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

which translates to

dpkg: error processing / var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb (- unpack):
      Trying to overwrite '/ usr/lib/i386-linux-gnu/libQt5MultimediaQuick_p.so.5.0', which is also in package libqt5multimediaquick5 5.0.0-0ubuntu1 ~ test2
     Errors were encountered while processing:
      / var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb
     E: Sub-process / usr / bin / dpkg returned an error code (1)

Ever since. I cannot install or remove programs. I have tried also:

sudo apt-get clean (and autoclean)
sudo apt-get -u dist-upgrade
sudo dpkg --configure -a

I have even tried the walkthrough on the following page:

How do I resolve unmet dependencies?

I still can't get it to work! Has anyone a suggestion?

Please help me to fix aptitude.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Just force overwrites on the installation of the conflictive package:

sudo dpkg --force-overwrite -i /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb

If that's not enough for the installation to succeed, you can also force everything dpkg can complain about (be careful doing this!):

sudo dpkg --force-all -i /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb

After doing that, just issue the suggested command again:

sudo apt-get -f install
share|improve this answer
    
Thanks this works :) –  Ashley Johnson Feb 19 '13 at 0:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.