Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to deactivate the amplification feature on my sound volume slider. Using any amplification makes the sound really bad with clipping sounds taking over.

It's really annoying to have to worry about where the amplification starts/stops when adjusting the slider from my keyboard or through the Gnome panel (sound thingy). I have to open the "Sound preferences" after each time adjusting the volume and ensure that the level is set to 100% unamplified.

So can I do this someway easy in Ubuntu 10.10?

share|improve this question
    
Why "just don't do that" recipe isn't working for you? –  ulidtko Feb 11 '11 at 16:40
    
Cause it's really annoying to only use 30% of the full width of the slider in the gnome panel and not be able to se where the amplification begins/stops, without having to open Sound preferences window and adjust it... –  Industrial Feb 11 '11 at 16:44
    
Looking forward to some more ideas - Bounty is ON! –  Industrial Feb 19 '11 at 10:32
    
Would love to chip in with a bounty of my own, but don't know how or if I can add to an existing bounty. Anyway, a temporary solution would be to keep the volume at two bars of the default icon, I always keep it that way. –  Oxwivi Feb 19 '11 at 10:47
1  
Yep, that's what also do right now - however it would be well worth the bounty to get some more people to look into the issue! –  Industrial Feb 19 '11 at 11:18
show 3 more comments

5 Answers 5

up vote 4 down vote accepted

Actually, you CAN slide all the way up: when using the indicator applet icon, the max slider IS 100% unamplified

To raise it ABOVE 100% (ie, to use amplified levels), you must go Sound Preferences.

So, when using the applet icont, go ahead and dont worry, it wont be amplified.

You can check this yourself: open the Sound Preferences window, and leave it open, visible on the desktop

Now access the indicator apllet icon, and slide up and down the volume level. Compare them (both will slide at the same time), and you will see that, using the applet, you can only go as far as 100% unamplified.

Hope that helps!

(i also had the same concern when i started using Ubuntu.. its a huge relief when you realize you dont have to open Sound Preferences anymore to "adjust" it ;)

share|improve this answer
    
I don't know about that, I've never messed with Sound Preferences, but going 100% from the indicator applet breaks the sound. –  Oxwivi Feb 20 '11 at 7:36
1  
@toki, maybe your issue is realted to speakers quality. My laptop also gives bad sound even if its not amplified (like 90% already sounds bad). But the original questioner has a different issue: he was worried about beyond-100% values, the amplification that Sound Preferences allows. He said that 100% works fine. And I answered that the applet icon respect that limit, and dont go above 100%, and amplified values can only be achieved in Sound Preferences. –  MestreLion Feb 20 '11 at 11:31
1  
Pardon me, but you are mistaken on both points. First, it's not something to do with my hardware because on Windows I don't detect any distortion in sound with full volume unlike on Ubuntu, and I've experienced the same thing with the laptop I bought recently. Secondly, as you can read in the comments under the question, the questioner clearly mentions that he keeps the sound level at two bars to avoid distortion in reply to my suggestion to do so - I fail to see where he mentioned that it works 100% fine. –  Oxwivi Feb 20 '11 at 13:38
    
Thanks for your answer @Mestrelion. I've tried your recommendations and it appears that when going over the "unamplified" mark, sound becomes unstable, really unstable and begins to crackle/pop almost immediately :( –  Industrial Feb 23 '11 at 16:26
add comment

I always install the pulse audio volume control its official name is "pavucontrol", available in the software centre. With Music player playing adjust the playback volume. I find 80% improves the sound as it appears most players, always set their outputs at 100% and this distorts on my laptop. Note this is independent of your volume control.

share|improve this answer
add comment

PulseAudio sets 100% to what the driver of your sound card reports as "100%, unamplified". If the driver reports incorrect values to PulseAudio, there is no way for PulseAudio to know there is something wrong, and you will get distorted sound when playing loud sounds at 100% (or when the error is in the other direction, you get sound that is not loud enough).

You will have to report a bug against the driver for your sound card, which you can do by executing ubuntu-bug audio, answering the questions, and explaining in your bug report on Launchpad what your problem is. Do not just add your comments to another bug of somebody with the same or a similar problem but report your own bug; there are several driver/hardware combinations with this issue and each might need a different patch/workaround in the driver, and the 'ubuntu-bug' command attaches all necessary hardware-information to the bug report.

share|improve this answer
add comment

Sound preferences (gnome-volume-control) only shows the master PulseAudio volume slider. What you are looking for are in the alsa mixer controls. I recommend that you install the package gnome-alsamixer Install gnome-alsamixer and then start the application by the same name. This should allow you to tweak your sound card setting including disabling amplification.

share|improve this answer
add comment

If you have a nice hifi system (like I do), then your best option is to get rid of pulseaudio completely and use hardware volume control from alsa directly. It makes a BIG difference. just apt-get remove pulseaudio You will lose a bit of flexibility (like playing lots of sounds simultaneously), but it will really make for much better sound experience.

share|improve this answer
    
If the drivers for your sound card work correctly, there should be no need for that. If they don't work correctly, you should file a bug report before using any workaround. –  JanC Feb 23 '11 at 23:03
    
Have you ever heard a GOOD HiFi system? Do you at all know what kind of quality am I talking about? Pulseaudio really spoils sound quality and the better your sound system is, more obvioius the difference is. I'm talking about a high quality external USB digital-to-analog converter, high quality amplifier behind it, ending with good speakers. Not your ordinary "sound card". Just go hear some such system, and then come back to teach me to fill bug reports. But I am sure, you will very much agree with me then. –  loxs Feb 24 '11 at 10:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.