Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Will there be a way to disable auto-hide behavior of global application menu in Unity. While I would prefer to have this behavior disabled by default (as it is bad UX), it looks like it's here to stay, so I'm wondering if, as a user, I will be able to turn it off.

share|improve this question

3 Answers 3

12.04

The global menu cannot be prevented from autohiding using the standard Unity install.

Unlike previous versions of Unity where opening an application never showed the global menu, in 12.04, the global menu appears for two seconds after an application has been launched before fading.

... you can also delay the autohiding of the global menu for up-to 10 seconds

gconftool-2 -t int -s /apps/compiz-1/plugins/unityshell/screen0/options/menus_discovery_duration 10

or via gconf-editor:

enter image description here

third-party solutions

Recently ubuntu-forums published a solution to always display the global-menu (i.e. it never hides).

This solution involves adding a custom version of Unity to your installation. Thus - you are dependent on the PPA maintainer for future Unity releases etc. Whether this dog eats your cat - I'll leave for you to monitor the ubuntuforums thread. I will not vouch for its veracity or stability.


12.10 through to 13.04 and beyond

There is an implementation report which has some speculative suggestions as to the global menu including the ability to have the ability to always turn-on the global menu

Global menu in general (not only in Unity) is very unergonomic on large screens (see the attached screenshot) because if you have a small window somewhere near the low right corner you have to move the cursor all the way up to to panel to reach the menu. I understand why the global menu was used for the netbook edition (it saves space and most windows are maximized), but since Unity is intended to be for the desktop edition there should be an option to switch to the traditional position of the app menu. It would be welcomed by many desktop users.

A commonly suggested solution is:

[ ] Global Menu on
[ ] Global Menu off
[ ] Global Menu only for maximized windows

The default is usually suggested as either the first (on) or last (on only for maximized windows).


Desired change:

Implement the 'Enhanced Menu' project for 12.10. This project will address the issue described in this bug and also issues described in the duplicates of this bus. Note this is the 'official' bug that tracks the implementation of this project.

The following options will be added to 'System Settings/Appearance':

Menus
Location: Global/Local
Visibility: Hidden/Always displayed

After some abortive tries, this did not make it into the 12.10 release. However it has not been discounted yet - its looking for an implementer ... even Mark Shuttleworth himself is now involved with this one

It will get done when it's the top priority for someone. You, me, any other contributor, doesn't matter.

More details to follow during the 13.04 cycle... ;-)

... however 13.04 has arrived but no joy. Headover to the implementation report and delve in to submit a fix so that it gets into a future release

share|improve this answer
2  
13.10 arrived and still no joy. who thought this was a good design? Have they been fired? –  frumbert Jan 9 at 8:35

12.04

[according to this post the 'Menu always visible' option is gone from the unity-revamped ppa]

Now it's possible. The Unity Revamped PPA which provides Unity with two patches: Dodge Windows and minimize/unmaximize on click for the Unity launcher, has been updated yesterday with some fixes which aren't yet available for the Unity package from the official Ubuntu 12.04 repositories as well as a new patch that brings a much requested feature: an option to disable the application menu (global menu) autohide behaviour.

The option that lets you disable menu autohide in Unity was supposed to be included by default in System Settings for Ubuntu 12.04, but it didn't make it for some reason. Hopefully, this option will make it into Ubuntu 12.10 by default, but until then, you can use the PPA below to get an option to disable the application menu autohide behaviour.:

To upgrade to the latest patched Unity from the Unity Revamped PPA in Ubuntu 12.04 Precise Pangolin, use the following commands:

sudo apt-add-repository ppa:ikarosdev/unity-revamped
sudo apt-get update
sudo apt-get upgrade

Once the packages have been successfully upgraded, log out and log back in.

To get the menu to always be visible, you'll need to install CompizConfig Settings Manager:

sudo apt-get install compizconfig-settings-manager

enter image description here

Then open CompizConfig Settings Manager (CCSM), select "Ubuntu Unity Plugin" and on the "Experimental" tab, check the box next to "Menu Always Visible" (it's not checked by default).

share|improve this answer
    
Has this been removed from Compiz since this post? Running the current version of Compiz and the Experimental tab does not have this option. [I'm also perplexed why they would even decide to have the menus hidden by default, what is the benefit here?] –  Exupery Jun 15 '13 at 0:03
    
Are you using Unity Revamped? –  jasmines Jun 15 '13 at 14:46
    
I believe so, I added the ppa:ikarosdev/unity-revamped PPA and did update/upgrade (gave zeros for all though, so I probably had done this previously). –  Exupery Jun 15 '13 at 18:13
    
Try the new Unity Revamped PPA: webupd8.org/2013/04/new-unity-revamped-ppa-for-ubuntu-1204.html –  jasmines Jun 15 '13 at 20:21
    
The author mentions in that article that he wasn't able to find the option in Compiz either, nevertheless I tried anyway and while it did add other options in Compiz that weren't previously there, the always show option was still not there. Thanks anyway though, guess I'll just hope the option is added back someday. –  Exupery Jun 15 '13 at 22:21

The is suggested in the following bug. As a user you can vote for it.

Menus are hidden by default

share|improve this answer

protected by Oli May 1 '11 at 21:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.