Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

As you can see in this picture firefox doesn't show any word that is bold:

enter image description here

As you can see the some lines are not shown properly. For example first line of search result is :

How to Make_______4________3

which normally should be:

How to Make Firefox 4 Look Like Firefox 3

Here is another picture:

enter image description here

This is is more inconvenient, title in top of the page, menus in left side of the page, and some titles and menus in context are missing.

I already remove it and install again, still not working. Any idea would be appreciated. I have 12.10 installed (if it matters). Thanks in advance.

share|improve this question

marked as duplicate by Seth, Eric Carvalho, Flimm, LnxSlck, AgentCool Feb 19 '13 at 14:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I'm not understanding the question or problem here. Please elaborate a bit. –  mdpc Feb 18 '13 at 18:34
    
@mdpc: I think the problem is obvious: the bits of text on the web pages are supposed to be in bold, but Firefox for some reason is not displaying them. –  Flimm Feb 19 '13 at 9:26
    
Have you installed any fonts recently, or modified Firefox's fonts' settings? –  Flimm Feb 19 '13 at 9:27

2 Answers 2

What do you want it to look like? Assuming that you want it to acquire the same look as other applications, perform the following steps:-

  1. Download: User Chrome override file for Firefox
  2. You will see a directory (folder) in your home folder/.mozilla/firefox which consists of letters and/or numbers. Create a directory named "chrome" within that directory.
  3. Copy the downloaded file to the newly-created "chrome" directory.
  4. If you have KDE installed, in the application preferences within System Settings, make sure that GTK applications are set to use the proper GTK icon theme you want. You can also prevent GTK applications looking like KDE ones by changing the GTK theme within KDE's System Settings and/or turning off the option to apply KDE colours to non-KDE applications, but this will make GTK applications look out of place in KDE.

Hope this helps.

share|improve this answer
    
Try changing your Firefox font in Preferences, Content, Fonts & Colors, Advanced. –  Saurav Sengupta Feb 18 '13 at 19:26

Ok, I figured it out. I just changed the font settings.

In Preferences, Content, Fonts & Colors, Advanced, I unchecked

Allow pages to choose their own fonts, instead of my selection above.

and it's normal again.

share|improve this answer
    
Interesting outcome of that change. I'm curious what were your selections then? –  carnendil Feb 18 '13 at 23:15
    
@Seth: isn't that obvious? –  Mehdi Feb 26 '13 at 14:54
    
@Mehdi I don't understand. Isn't what obvious? –  Seth Feb 26 '13 at 17:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.