Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Sony VIAO SVS13112ENB which has a Insyde H2O bios with UEFI and enabled. It came with Windows 7 and then i upgraded it to Windows 8. Now I am trying to install and run Ubuntu with dual boot. I used LiveUSB to install Ubuntu.

When I reboot and boot into USB, i see this message: "Secure boot is not enabled" for a second, then i get grub-like option to "try without installing", "Install Ubuntu", "OEM installation" and "disk check" options. I carry along to install Ubuntu.

I created new partitions for root and swap, and used the already existing EFI partition. The installation wen't normal but when it is done is when i'm facing problem, when it reboots Windows 8 boots up like nothing ever happened.

I know ubuntu still have issues with UEFI. Was anyone able to overcome this? Am I missing anything here?

Please Help Me, I need to install Ubuntu on my laptop.

Thanks in advance.

share|improve this question
add comment

1 Answer

Some computers have buggy EFI implementations that either "forget" the EFI's boot loader NVRAM entries (which normally hold the order in which boot loaders are tried) or that ignore entries other than those for Windows. In such cases, you need to do a workaround, which typically involves moving and renaming files so that the Ubuntu boot loader is installed where the Windows boot loader resides. There are several ways to do this:

  1. You can use the Ubuntu Boot Repair tool. This should make the changes automatically; however, it does so by renaming the existing Windows entry in a way that could cause confusion or further problems down the road.
  2. You can download the bootable USB flash drive or CD-R image of rEFInd, use that to boot Linux, install the Debian-package version of rEFInd within Ubuntu, and then type sudo mvrefind.sh /boot/efi/EFI/refind /boot/efi/EFI/Microsoft/Boot. This will cause rEFInd, rather than GRUB, to come up as your default boot loader, and you should then be able to launch Ubuntu either directly or via GRUB.
  3. You can do it manually by mounting your EFI System Partition (ESP), moving its EFI/Microsoft/Boot/bootmgfw.efi file down one directory, copying EFI/ubuntu/grubx64.efi to EFI/Microsoft/Boot/bootmgfw.efi, and adjusting your GRUB configuration to launch the Windows boot loader from its new location. This is obviously both more tedious and more likely to create problems because of a user error than either of the previous two options; but if you know what you're doing (or want to learn), you might prefer to take manual control of it.

There are other possible solutions, particularly if my diagnosis that you've got one of these buggy EFI implementations is incorrect. For instance, you might need to run efibootmgr (with suitable options for your installation) manually from an Ubuntu emergency disc. It's also conceivable that there's a firmware update available that fixes the bug.

share|improve this answer
    
Hey Rod, That helped a lot. This was exactly what I wanted. I just went with step3. I had been searching for an answer for my problem in askubuntu and failed to get an answer. Finally, thanks to you I am able to boot into ubuntu. –  Nishanth Feb 20 '13 at 3:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.