Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Might already have been answered, but every single tries did not work, so I'm asking this here. So yeah, I can't manage to install the AMD proprietary drivers (neither can I for open-source ones), I've tried using different versions of the drivers, nothing worked.

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Broadway [ATI Mobility Radeon HD 6800 Series]

My machine is an Alienware M17X R3 laptop ( yeah I know, over expensive comp ), and I've set it up to dual-boot with Windows 7 (64x) and Ubuntu 12.10 (32x). Don't ask me why I picked a different type OS, I don't know. I know that it's kinda easy to install drivers for an AMD card on Ubuntu, but since mine is a Radeon / Intel Hybrid, most of the techniques I know don't work. Can someone help me on this one?

share|improve this question

marked as duplicate by Luis Apr 19 '13 at 22:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
How did you try to install the driver? What happend, if you try to install it? –  TIIUNDER Feb 18 '13 at 16:34
    
I tried everything on this page and this page. It would usually result in my computer booting into low-graphic mode, or just a black screen. Once tough it did get to the Ubuntu desktop, but when I typed fglrxinfo in terminal it returned errors. –  Jolain Poirier Feb 18 '13 at 16:51

1 Answer 1

Not sure if my problem is releated but its worth checking. I have a HP Eny 6 1006sa sleekbook that has an AMD A6-4455M APU with Radeon HD 7500G Discrete-Class Graphics. For a fresh Ubuntu 12.10 install I additionally installed the fglrx video graphics drivers, on reboot I log in and would get just a desktop wall paper image with no Unity desk top. Unity also fails to start from the command line. This was very repeatable. I looked at the package dependencies for the Radeon fglrx drivers and checked they were all present using Synaptic. I noted two Kernel packages were missing. Installing these packages following a fresh 12.10 install, enabled trouble free install of the fglrx and then fglrx updates graphics drivers. The two kernel packages missing were:

  1. linux-generic 3.5.0.17.19
  2. linux-headers-generic 3.5.0.17.19

see: http://www.divnut.com/Ubuntu/Screenshot_12p10_install_vrs_manifest.png

Haven't logged this as a bug yet as I'm not sure what to log it against, still investigating.

share|improve this answer
    
Thanks for the quick answer, although it didn't work. I already have the two kernel packages, so I re-installed them with sudo apt-get install --reinstall linux-generic. I also tried using legacy drivers but did not work either. –  Jolain Poirier Feb 19 '13 at 13:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.