Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to use Ubuntu 12.04 lts on a system76 box.

when I try to run the java debugger, jdb, i get a timeout after i attempt to run the application. i have tried several things and I think the problem has to do with the /etc/hosts file.

my call to jdb is very simple:

jdb main.RunSim where my main class resides

i have also tried calls that attempt to attach to an existing VM and get the same results

the /etc/hosts file is:

127.0.0.1 localhost
127.0.1.1 my machine name

a bunch of lines for ipv6 capable hosts including

::1 ip6-localhost ip6-loopback

any idea?

share|improve this question

1 Answer 1

Well, it could be anything, try running the whole session under strace, log it to a file to see where it might be hanging.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.