Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.10 Desktop on Vmware Player with Windows 7 as an host. I have given it 30GB or hard disk space and 3 GB of ram yet Ubuntu is lagging. When I right click or something, it takes around 3-4 seconds to show the menu.. Can't it work faster? Any ways? I had tried installing ubuntu with dual boot with windows using a bootable usb(made using the link given on ubuntu's official site) but some error occured and it wasn't able to install. Even windows was not booting and i had to repair it that is why i am running it on VmWare. Please help me make it work faster.. I hate lag :( Thanks. -Ryder

share|improve this question
    
There is a known issue with Ubuntu 12.10 using the Unity desktop on some virtual machines to do with GPU. Not sure if it applies to VmWare. On possible solution is to change the desktop to something else such as Gnome Classic. On my machine this made a massive difference in 64bit Win7 host and Virtualbox. To install sudo apt-get gnome-panel log out then back in selecting Gnome Classic as your desktop. –  Warren Hill Feb 18 '13 at 13:11
    
It says E: Invalid Operation gnome-panel –  Ryder Feb 18 '13 at 13:43
    
Sorry the command should have been sudo apt-get install gnome-panel –  Warren Hill Feb 18 '13 at 13:54
    
Thank You!!!It worked. By Ubuntu is faster than ever.. –  Ryder Feb 20 '13 at 4:15
    
As this worked for you I have added it as an answer. Please accept it so that other users who have the same problem can find it and be helped too. –  Warren Hill Feb 20 '13 at 6:55

1 Answer 1

up vote 2 down vote accepted

There is a known issue with running Ubuntu 12.10 inside a virtual machine such as Virtualbox or VmWare.

The Unity desktop is reliant on the Graphics processor which is not supported in many virtual machines -- see here.

This was not an issue in 12.04 as it had the Unity 2D desktop as an option for slower machines.

If you have a powerful enough machine you can try giving Ubuntu more than one core.

Alternatively you can use another desktop: To use the "Gnome Classic" desktop which is similar to the desktop as used in 10.04 open a terminal with CTRL+ALT+T and enter

sudo apt-get install gnome-panel

log out then back in selecting Gnome Classic as your desktop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.