Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently defenestrated this laptop and I'm having some issues with the graphics.

I'm seeing some pretty nasty screen tearing on this thing. I didn't notice any while the machine had windows 8 (a brief amount of time, admittedly) which leads me to suspect some kind of driver issue.

Googling led me to some tearing issues from ATI drivers and the new version of X but since most posts are a bit dated I don't know if that is what is happening to me.

The machine is a g6-2211nr model with an AMD A4-4300 APU and it's running 12.10.

The computer details dialog is showing "Driver: Unknown"

Any ideas?

EDIT:

I installed the proprietary drivers. Upon reboot I reached the login screen and it looks flawless. However, after accessing my account, I can only see the desktop background and the mouse pointer. Nothing else.

I successfully reset everything. I'm back in but the screen tearing is back. I checked to see if the tearing appears during the login screen with this "working" configuration that uses the opensource drivers and no, tere is no tearing during the login screen no matter how hard I try to bring it about.

Here is the output of lshw -c video right now:

*-display               
description: VGA compatible controller
product: Advanced Micro Devices [AMD] nee ATI
vendor: Advanced Micro Devices [AMD] nee ATI
physical id: 1
bus info: pci@0000:00:01.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:48 memory:e0000000-efffffff ioport:3000(size=256) memory:f0300000-f033ffff

Aside from a fix, isn't there a way to just turn off hardware acceleration altogether? Just CPU render the whole thing?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Have you installed the proprietary AMD graphics drivers? If you haven't you should do that. Many AMD cards don't work very well with the included open source driver.

If you are on Ubuntu 12.10, open the Ubuntu Software Center, go to Preferences -> Software Sources and look under the "Additional Drivers" tab. Check out this answer.

If you use Ubuntu 12.04, start the "Additional Drivers" untility directly from the dash. (Just type "drivers" or "jockey") Guide here.

BTW, AMD drivers are a lot more stable on 12.04. So if you don't already use that and don't get it fixed on 12.10, you might consider using 12.04.

share|improve this answer
    
Didn't work. Check out my edit of the OP. Do you know of a way to turn off hardware acceleration in the meantime? –  CptAJ Feb 20 '13 at 5:55
1  
I installed 12.04, it has the same tearing under the open source drivers but this time the proprietary ones DID work. I think I'll leave it like this for now. Thanks for the help! –  CptAJ Feb 20 '13 at 17:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.