Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was changing something in Nvidia Settings/COnfig in XFCE and now when I book to X screen is blank. I tried to book in console mode, worked, and when I try to launch nvidia-settings from the term I get no control display...

Any quick tips?

EDIT1:Guys when I login in console mode (RECOVERY MODE) I can't delete .nvidia-settings-rc because it says file system is in read only mode...

And I don;t know how to kill Xorg in normal mode.. I'm stuck with a black screen.. Tried alt+ctrl+backspac,e tried alt+sys rq+k... nothing works!

EDIT2:I used mount -o remount,rw / and deleted both nvidia-settings-rc and xorg.conf. A new file was generated, but I still go to black screen as soon as X is started.

EDIT3 Even though the problem seemed trivial, I lost more than two days trying to fix it and decided to format and put a clean image of xubuntu. It seems one should be careful when changing stuff from nvidia settings. But for now I'm sticking with nouveau driver...

share|improve this question
How much time/work do you lose if you just reinstall X (or the whole OS)? I always consider reimaging an acceptable solution if it costs me less time then I've spent trying to fix a problem. – Jesan Fafon Feb 22 '13 at 6:10
That's what I did. I had experimented with many packages and guis so I just got latest xubuntu and also got rid of my windows partition. The problems always came from the. Nvidia driver and settings app so for now I'm sticking with nouveau...I don't know how much I'm missing but I guess not much as I'm just doing dev work.. – George Katsanos Feb 22 '13 at 7:20

Remove the file and it should start a fresh config for you. Also, if you used root/sudo for editing (which I suggest you NOT do) then you'll probably have to remove the xorg.conf file and rerun nvidia-xconfig.

For that second bit I suggest waiting for a confirmation thru someone else.

share|improve this answer
I tried to delete it while being root but it didnt allow me. I am running X as root so I guess the system was changing it in root mode... I don't know how to do a rootless X but thats another story! – George Katsanos Feb 18 '13 at 8:29
You have to be able to delete it as root. It isn't called "superuser" for nothing. ;) With "sudo rm" you can delete everything. And: How do you start X? You should never run X as root because of the aforementioned superpowers. – Béné Feb 18 '13 at 12:55
I know I know, I am well aware, but I somehow didn't prioritize that, I was setting up Ubuntu as a dev / testing environment.. but now I can do it if you have a good how-to? So I'll try to delete .nvidia-settings-rc (although I am sure I couldn't because it was in use or something) and then the xorg.conf file.. (where is that one?) – George Katsanos Feb 18 '13 at 16:15
I connected on recovery mode... rm: cannot remove .nvidia-settings-rc : read only file system – George Katsanos Feb 18 '13 at 18:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.