Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting dependency package errors as:

root@osscube:/home/abdul/Downloads# dpkg -i mysql-workbench-gpl-5.2.47-1ubu1004-amd64.deb
Selecting previously unselected package mysql-workbench-gpl.
(Reading database ... 153925 files and directories currently installed.)
Unpacking mysql-workbench-gpl (from mysql-workbench-gpl-5.2.47-1ubu1004-amd64.deb) ...
dpkg: dependency problems prevent configuration of mysql-workbench-gpl:
 mysql-workbench-gpl depends on libmysqlclient16 (>= 5.1.21-1); however:
  Package libmysqlclient16 is not installed.
 mysql-workbench-gpl depends on libpython2.6 (>= 2.6); however:
  Package libpython2.6 is not installed.
 mysql-workbench-gpl depends on libzip1 (>= 0.9); however:
  Package libzip1 is not installed.
 mysql-workbench-gpl depends on python-paramiko; however:
  Package python-paramiko is not installed.
 mysql-workbench-gpl depends on python-pysqlite2; however:
  Package python-pysqlite2 is not installed.
dpkg: error processing mysql-workbench-gpl (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
Errors were encountered while processing:
 mysql-workbench-gpl

I have tried to run apt-get -f install, but I didn' have any success. I have also tried to install these dependent packages as:

apt-get install libmysqlclient16 libpython2.6 libzip1 python-paramiko python-pysqlite2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libmysqlclient16 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libpython2.6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libzip1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libmysqlclient16' has no installation candidate
E: Package 'libpython2.6' has no installation candidate
E: Package 'libzip1' has no installation candidate

How do I fix this?

share|improve this question
    
Enable all the repos and do an apt-get update –  Tachyons Feb 18 '13 at 7:48
    
So why do you use dpkg -i with 1 and apt-get with the others? Why not dpkg -i the dependencies too? –  Rinzwind Feb 18 '13 at 8:00
    
@Abdul: did you solved this issue –  gowri Mar 12 '13 at 22:17
    
@gowri : Yes i have solved this issue –  Abdul Manaf Mar 13 '13 at 5:39
1  
@AbdulManaf You can post your solution and accept it. This will help others with the same issue. –  gsc-leticia Aug 9 '13 at 13:42

4 Answers 4

Have you tried with gdebi? I've successfully installed it with the following:

sudo apt-get install gdebi-core
sudo gdebi ~/Downloads/mysql-workbench-gpl-5.2.47-1ubu1204-amd64.deb

Unlike apt, gdebi able to correctly resolve the dependencies.

share|improve this answer
    
I tried your solution, but still issue is not solved –  gowri Mar 12 '13 at 22:15

It's easy just to go to Ubuntu Software Center and type

mysql-client

and install it so your dependencies also install. Then open a terminal and type:

sudo -i
dpkg -i package.deb  <use your package name here>

I guess it will work.

share|improve this answer

This might not be the preferred method, but I install it from the site.

http://dev.mysql.com/downloads/tools/workbench/

If you are on 12.04 it is pretty outdated and programs like MySQL workbench are good programs to get the latest and greatest features.

share|improve this answer

Use this command

sudo apt-get upgrade
sudo dpkg --force-all -i mysql-workbench-community-6.0.8-1ubu1304-amd64.deb

and to remove it

sudo apt-get -f install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.