Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am experimenting with nginx+uswgi+Flask and am following this tutorial. However when I get to the portion for creating a new user for uswgi I am having troubles.

When I enter the command from the snippet the error I get is

$ sudo adduser -c 'uwsgi user,,,' -g nginx -d /nonexistent -s /bin/false uwsgi
Option g is ambiguous (gecos, gid, group)
Option d is ambiguous (debug, disabled-login, disabled-password)
Option s is ambiguous (shell, system)
...

I am by no means a ubuntu pro but after doing a little research I think the options I want are

$ sudo adduser -c 'uwsgi,,,' --group nginx --debug /nonexistent --system /bin/false uwsgi

however the error this returns is:

adduser: Only one or two names allowed.

here is my version information (if that helps)

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04 LTS
Release:        12.04
Codename:       precise

So my question is what options should I be using to successfully create a uwsgi user such that I can complete the tutorial?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You are using wrong command. Use useradd instead of adduser:

sudo useradd -c 'uwsgi user,,,' -g nginx -d /nonexistent -s /bin/false uwsgi
share|improve this answer
    
oh duh... +1A. Thanks!!! –  John Feb 18 '13 at 0:25

If you are using some examples from the net, like I did, it's easy to miss that some characters copied from web are not the valid characters in console (like dashes, quotes etc.) Here is a blog post where I had found this clue (luckily for me)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.