Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 on my Thinkpad T400 ... but I have no sound and the keyboard buttons for volume up and down do nothing. When I open sound settings, there's nothing: it's all greyed out. It is like the driver is missing.

Alsamixer gives :

card :HDA Intel                              
chip: Conexant CX20561 (Hermosa) 

What can I do?

T400:~$ sudo aplay -l

**** Liste des Périphériques Matériels PLAYBACK ****
Home directory /home/louisro not ours.
carte 0: Intel [HDA Intel], périphérique 0: CONEXANT Analog [CONEXANT Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Intel [HDA Intel], périphérique 1: Conexant Digital [Conexant Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

T400:~$ lspci -v | grep -iA 7 'audio'

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Lenovo Device 20f2
Flags: bus master, fast devsel, latency 0, IRQ 49
Memory at fc020000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel

enter image description here

In the upper bar the sound icon is not functionning: enter image description here

The sound works out of the box with a live USB ubuntu with /etc/modprobe.d/alsa-base.conf containing the following:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
share|improve this question
    
post the output of sudo aplay -l. Please post also the output of: lspci -v | grep -iA 7 'audio' –  phipsalabim Feb 18 '13 at 0:31
    
just did it. thanks –  louis Feb 18 '13 at 9:36
add comment

2 Answers

Driver is ok.

Open alsamixer, make sure your output channels are not muted. Press the left and right arrow keys, to move to different channels and press m to toggle mute / unmute. A "M/M" at the bottom of a column means it's muted

It should look kinda like this:

alsamixer screenshot

share|improve this answer
    
thanks but I checked and they were not muted...still no sound –  louis Feb 21 '13 at 20:26
    
try: /usr/bin/amixer -c 0 sset "Auto-Mute Mode" Disabled –  phipsalabim Feb 21 '13 at 20:39
    
run: gksudo gedit /etc/modprobe.d/alsa-base.conf and add this line options snd-hda-intel model=thinkpad. You will have to reboot. If that doesn't help try resetting your BIOS to factory defaults. –  phipsalabim Feb 21 '13 at 21:05
    
I did the auto-mute command and added the line in the alas-base.conf file, still no sound ! I also reset the bios to factory settings ...still nothing, any other ideas? –  louis Feb 21 '13 at 23:16
    
Full disclosure: I'm stumbling in the dark. Please try changing the line in the conf file to option snd-hda-intel model=generic, reboot. –  phipsalabim Feb 21 '13 at 23:25
show 10 more comments
up vote 0 down vote accepted

My /home is mounted from a separate partition, and this partition was ntfs, so there was permissions problems...Now I formatted this partition to ext4....and the sound works!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.