Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After some wrestling with nvidia drivers and compiz, I got everything up and running, only to find that using Ctrl Alt Shift doesn't move windows to different workspaces anymore.

Clicking the window and dragging it to another workspace works fine, but if I use Ctrl Alt Shift to move windows it flickers in the new workspace for a second before going back to the original workspace.

I checked my compiz settings and all seems to be well...

currently running:

  • Composite
  • Gnome compatibility
  • OpenGL
  • Desktop Cube
  • Rotate Cube
  • Animations
  • Blur windows
  • Fading windows
  • Window Decoration
  • Wobbly Windows
  • All image loading
  • Compiz library toolbox
  • mouse position polling
  • Regex matching
  • Workarounds
  • Application Switcher
  • Move window
  • Place windows
  • Put
  • Resize window
  • Scale
  • Shift switcher

I've tried running:

compiz --replace 

... but it doesn't do anything. Worse, it tends to hang in the terminal and I have to kill the terminal.

The workspace panel in the taskbars also doesn't reflect what's on the screen, showing that I'm on the first workspace panel when I'm not, and also not showing the windows on the other workspaces. Not sure if that info helps, but that's what it's doing.

share|improve this question

1 Answer 1

As cube rotation with the window is still broken you can use a workaround. In the properties of the cube rotation plugin disable the shortcuts Ctrl+Alt+Shift+Left/Right. Activate Put plugin. Then in its properties, in "Put to adjacent viewport" section set your shortcuts for the Left and Right viewports.
Instead of moving to new viewport with the window simultaneously now the window will move to new viewport and then the viewport will promptly follow the window. Almost the same functionality.

BTW, activation of some plugins in my system (Ubuntu 12.04.2 LTS, GNOME Classic session and Compiz 0.9.7.12-0ubuntu2) with ccsm crushed my Compiz and cleared all checkboxes of my active plugins. Put was among them. In order to activate this plugin in more safe way you can edit the file ~/.gconf/apps/compiz-1/general/screen0/options/%gconf.xml and add into it some lines directly:

<li type="string">
    <stringvalue>put</stringvalue>
</li>

Then reboot your system.
P.S. If you are not using Gnome Classic try another locations to find your Compiz config file: http://askubuntu.com/a/223905

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.