Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've downloaded the .iso file (ubuntu-12.10-desktop-i386.iso), and then used Unetbootin to make my 16Gb Kingston pendrive a live-USB. Then I restart my notebook (samsung r580) and access the BIOS. I select the option to boot from USB, and restart again. The options screen appears. So far, everything is fine.

I choose Install Ubuntu, then I select the language and then I try to select install alongside an existing W7. Here is where I have trouble. Clicking "continue" restarts the system, and the option screen appears again and again and again.... What am I doing wrong?

Oh, I also did the checksum, it's just fine.

EDIT

Ok, I've tried several options in the BIOS (enable/disable Legacy OS Boot and Large Disk Access Mode) and... still not working

I went to test the Live version and tried installing from there. It asked me to unmount partitions, I selected no, and that wouldn't allow me to install inside Windows 7, so I went back and selected yes, showing me again that option. Then I selected the 'Something else' option and there I saw the following info:

sda ATA SAMSUNG HM321HI

sda1 ntfs 16106MB 12447MB Windows Recovery Environment (loader)

sda2 ntfs 104MB 35MB Windows 7 (loader)

sda3 ntfs 151928MB 75593MB

sda4 ntfs 151930MB 3221MB

I know these are the partitions of the HDD, sda3 and sda4 being C: and D: respectively. These 4 partitions are ntfs formated, maybe this is what is wrong? Do I have to format sda4 with FAT32 or something? Add a new partition so sda4 becomes a loader sector?

For the guy that says I should use Universal USB installer, I have the same problem with it, it restarts for ever. Thanks anyway.

UPDATE

Following @Sand Dust's comment, I did have 4 partitions, so using the installer I could set the sda4 partition (D:) as free space (un-allocated?)

After reading a lot (lol), I've created 3 partitions manually: / (30GB ext4), /swap (6GB) and /home (96GB ext4). And then... finally! install begun.

However, after restarting, it goes straight to Windows.... right now I'm in the live version and I see the / and /home directories, so I guess the install process went just fine.

What's wrong this time? Could it be something about GRUB? I'm gonna keep reading...

share|improve this question
    
If you want to install along side Windows 7, you have to install Ubuntu in a partition different than the C: (because there is Windows) but it has to be more than 5Gb free. You can resize the partitions so you will have space to create the partition. –  Lucio Feb 18 '13 at 2:08
add comment

3 Answers

So, finally got it solved. The aim of the question was that I couldn't install from the Live-USB, because it restarted over and over again. The problem was the partition of the HD (in Ubuntu terms, the sda device). It had 4 partitions, as @Sand-Dust mentioned, and all 4 of them were primary, with only one of these partitions empty, so there was nowhere to install Ubuntu (since from what I learned, it needs at least 2 partitions to install). The solution then was to ¿un-allocate? the partition sda4 (D:) and create 3 partitions in this now empty free space, all of this partitions being logical. You can do this with the installer, under the 'Something Else' option.

So after this, I've got Ubuntu intalled, but when restarting, it didn't show me the OS options, and started Windows... instead of messing with the GRUB, or Boot Repair, I chose to re-install Ubuntu, and now I'm writing from it.

Thanks for the comments and help.

share|improve this answer
    
+1 because it makes sense. However, I'm going to test it now. cuz I'm having pretty much the same problem. thank you –  mamdouh alramadan Sep 4 '13 at 5:43
    
done. commenting from ubuntu. :D thanx –  mamdouh alramadan Sep 4 '13 at 7:45
add comment

Did you format the USB as Fat32? For the boot to work properly, it has to be Fat32.

Also, make sure that there are no CD's, other USB's or something like that connected.

share|improve this answer
1  
Yes, the USB is FAT32 formated, and there's nothing else connected. –  Dimitrosky Feb 18 '13 at 1:36
    
The problem is not the boot, the OP says that he boot from LiveUSB fine and he can see the Ubuntu install process. –  Lucio Feb 18 '13 at 2:09
add comment

You should not use UnetBootIn, use Universal USB installer, get it from here: http://www.pendrivelinux.com/

share|improve this answer
    
I also tried with it, the same thing. –  Dimitrosky Feb 18 '13 at 1:37
    
I think: you have 4 PRIMARY PARTITIONS. So when Ubuntu try to add a new partition (by truncating from one of those), Ubuntu could not. One of your partitions must be a EXTENDED PARTITION, so Ubuntu can split the extended partition into several logical partitions, thus it can make new partitions. Then you can try to install Ubuntu again. Now make a logical partition your self, from 4th partition. You can use Hiren's Boot CD to make D: a LOGICAL PARTITION (at that time, D: will have already been inside an extended partition). –  Sand Dust Feb 18 '13 at 2:51
    
Remember: DON'T format D:, just CONVERT D: into a LOGICAL PARTITION. –  Sand Dust Feb 18 '13 at 2:57
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Manishearth Feb 18 '13 at 12:48
    
@Dimitrosky: When you are in the live version, / and /home is DIRECTORIES on RAMDISK (a virtual file system on RAM). But did you see the message: INSTALLATION COMPLETE! ? I think GRUB might not be installed. PLEASE READ THIS CAREFULLY and install GRUB: gnu.org/software/grub/manual/html_node/… –  Sand Dust Feb 18 '13 at 14:33
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.