Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My former nVidia proprietary driver (295.40), and all others before it that I can remember, used to stretch any full screen application running bellow my monitor resolution to fill the entire screen by default. Even applications running through Wine.

However after upgrading the driver to version 310.32 this behavior was lost, meaning the application runs on the resolution is set to, and a black border is draw around it to fill the void.

Is there some option I can apply to xorg.conf to re-enable this behavior once again?

The nVidia GUI (NVIDIA X Server Settings) does not possess such option, and after going through the driver options documentation for my version, I couldn't find (clearly) any option who could be applied to xorg.conf who would re-enable this behavior.

Thank you.

Ubuntu 12.04 LTS 64 bits

X.Org Version: 1.11.3

nVidia GeForce 9300M GS (nVidia Proprietary driver 310.32)

Update 1:

I've double checked my xorg.conf and the option "NoStretch" is not present, therefore it should stretch to fill the screen. However not sure why it does not.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.