Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Where is the X.org config file? How do I configure X there?

I'm trying to get my video card properly setup to handle 3D acceleration. After searching a bit, I've come across a few howtos that tell me I need to edit my xorg.conf file. That file doesn't exist. X.org is installed by default, I'm sure, and I figured this video card would be widely supported.

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)

Any ideas on how I can get this to work properly and play Starcraft II? Or any game for that matter? No resolution problems or anything, just no 3D rendering.

share|improve this question

marked as duplicate by Marco Ceppi Feb 11 '11 at 14:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 8 down vote accepted

You COULD create your own xorg.conf by typing in a tty (not running gdm) the following:

X -configure

That will create a file called xorg.conf.new

To test the file type X -config xorg.conf.new

If you can load X and see the mouse and a good resolution then you can press CTRL+ALT+BACKSPACE to quit.

Copy then xorg.conf.new to the new location

cp xorg.conf.new /etc/X11/xorg.conf

Run startx to test.

Also the file does not exist since X.org does not needed anymore for some video cards (as i understand) only some Video cards have xorg.conf because of specific configurations (Like Nvidia and Ati). The rest of the X.org configuration options are in /usr/share/X11 like synaptics.

Now to test out if you have Direct Rendering do this:

glxinfo | grep -i "Direct Rendering" If it says YES then you can run several games. If it says NO then you might need more configuration. Also run glxgears to see how many FPS you have. If the glx commands are not there run sudo apt-get install mesa-utils

I can not guarantee that it will make it work for starcraft 2 (Remember you also need to have wine installed)

share|improve this answer
1  
after some poking around, I found out it's a problem with Starcraft II, not my drivers. Accepted because the answer is relevant to the question, but the question I asked was in fact, the wrong one. –  BBetances Feb 11 '11 at 2:51
    
Thanks for this excellent answer! I had no idea that X had a -configure flag. Is this new? –  koanhead Feb 11 '11 at 3:55
    
"The rest of the X.org configuration options are in /usr/share/X11" This is ridiculously useful information that I haven't seen anywhere else. –  djeikyb Feb 11 '11 at 4:38
    
grep -i is better for "testing" direct rendering, since output of glxinfo has that text with lower case, at least on my machine ... –  LGB Feb 11 '11 at 8:13
    
Correct LGB. Added. Thank you. –  Luis Feb 11 '11 at 11:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.