Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently VLC has been having issues displaying video in fullscreen mode. AFAIK, nothing has changed with the video card drivers and it's certainly the same version of VLC. (/me shakes a fist at the repository maintainers)

This has worked without issue in the past. In fact, I've had as many as 6 instances of VLC running, each playing a video. One was always fullscreen on my second monitor, while the others were tiled on my primary monitor. I was able to toggle any of the other 5 into fullscreen mode and the video displayed without issue.

Lately, I've been having trouble running 2 instances in fullscreen mode. (Sometimes, even a single instance will not display the video in fullscreen.) VLC will continue to play the video, but in fullscreen mode I see nothing but a black screen. Sometimes, the video will display if I maximize the VLC window. Other times, I have to settle for a smaller sized window.

I don't know if this is pertinent, but sometimes changing the min/max state of a Firefox window (Minefield, specifically) seemed to allow the troublesome instance to display the video in fullscreen mode. However, that did not prove to be a consistent workaround. Sometimes, it seemed that closing a Firefox window did the trick, though that isn't consistently successful either. (I futzed with Firefox, because with the crazy number of windows and tabs that I normally have open, it regularly hogs about 1 GB of RAM.)

Another bit of funkiness that comes to mind is the fact that my secondary monitor is considered the primary on boot-up. I use xrandr to designate the real 1st monitor as primary after boot-up, as suggested by someone in a question I asked on the Unix & Linux SE site.

Specs:

  • Ubuntu 10.10 w/ Gnome and Compiz
  • 8GB RAM
  • AMD Phenom II 965 Black Edition
  • Asus M4A79 Deluxe mobo
  • XFX ATI Radeon HD 5750 w/ 1GB RAM

VLC is configured to use the hardware overlay for video (as per the default setting)

Does anyone have an idea what may cause this issue or how I may go about troubleshooting it? Right now I have 2 instances of VLC playing, each in fullscreen mode on a separate monitor.

share|improve this question
1  
@jorge I don't understand how a black screenshot would shed any light on the situation. :) –  George Marian Feb 11 '11 at 0:40
    
Yeah it's just hard to visualize where you explain about having multiple instances and on which monitors you want to do what on. –  Jorge Castro Feb 11 '11 at 0:49
    
@jorge It doesn't matter which monitor the troublesome instance of VLC is using. Sometimes, an instance that is displaying correctly in fullscreen mode will run into this issue if I toggle fullscreen mode on it. Imagine one monitor displaying a video in fullscreen mode, while the other monitor displays nothing but black and the VLC fullscreen control interface if you hover over it. –  George Marian Feb 11 '11 at 0:53
    
It's possible that usage of XVideo is limited, I mean, not more than some given number of X clients can only use XVideo at the same time. I have no idea about VLC but you can test mplayer with "-vo xv" to use XVideo. If you have this bug, try with "-vo x11" (much more CPU usage, no hw scaling then etc) if it works, I guess it's some problem with XVideo extension of X. –  LGB Feb 11 '11 at 8:15
1  
1) Turn off compiz (advanced visual effects) in Appearance Preferences. If that does not help try adding the radeon.modeset=0 boot parameter to your kernel command line. Also do you have any PPAs? –  komputes Mar 1 '11 at 21:03
show 4 more comments

4 Answers

Given the number of good answers, if you are still having problems - I suggest filling a bug report with vlc and launchpad. (Search for similar bugs first.)

share|improve this answer
add comment

Not knowing much about computers, you might try this:

http://forum.videolan.org/viewtopic.php?f=13&t=78308

from VLC

share|improve this answer
    
That page mentions 'without a window manager' so it doesn't apply in this case. –  Nathan Osman Aug 20 '11 at 22:11
add comment

Two things you should know about VLC:

1. If you have compiz activated you will have some issues with VLC showing the video from a movie.

2. If you have multiple displays it will have some issues with VLC choosing which display to show the video in.

So for what i have read, you have both of this. From my experiences with similar cases i recommend to disable compiz and afterwards test the displays. To disable compiz just ALT+F2 and type metacity --replace or you can just go to System -> Preferences -> Appearance and select the Visual Effects Tab then select none.

Second, to test the display problem.

First test if you can see the video on 1 display (without the other one connected).

Second test (with the video closed. Do not open it yet) with both monitors connected and in "clone mode". Run the video and see if it appears in both displays.

Third and last, remove the "clone mode". Put one to the right or left and open 2 instances of VLc. move one of the instances to the left/right display and the other one leave it on the base display.

this is the way i do when i have black screen issues with vlc. This is because of some issues with compiz and with having multiple displays since VLC does not know to which to show the display.

Test all this and let us know.

share|improve this answer
    
My apologies for taking so long to respond. VLC generally works, displaying on either monitor. Occasionally, it will glitch and display fullscreen on the wrong monitor. (I'm not certain if that glitch has it displaying on the primary monitor every time or the one on which VLC appeared when it launched.) Regardless, that's not a big deal. Toggling fullscreen once is usually enough to clear that issue. –  George Marian Apr 22 '11 at 19:23
    
The problem is that under some circumstance(s) fullscreen mode will display nothing but the black background. I have tried turning off compiz, but that didn't solve the problem It made it less likely that it would crop up, but it didn't solve it. Note with regard to the two monitor setup, that generally seems to be working for me. When VLC is having this issue, it will occur on either monitor. –  George Marian Apr 22 '11 at 19:27
add comment

In Tools > Preferences > Video > Output change the Default to X11, save and restart vlc.

share|improve this answer
    
This problem continues in Ubuntu 13.04 on proprietary AMD drivers and can still be solved as above. –  holocronweaver Aug 20 '13 at 4:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.