Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I open a PDF file, it doesn't display text. Graphics show up.

How do I get the PDF viewer to display text?

share|improve this question
3  
Also, what is the actual name of the PDF Viewer you are using? Can you run it from a terminal? Any errors reported there may help diagnosis. –  user25656 Feb 17 '13 at 18:11
3  
Open this PDF form with your PDF viewer and take a screen-shoot, then upload it to Imgur and link it into your question. NOTE: You can know the name of your application in the About menu. –  Lucio Feb 17 '13 at 18:43

3 Answers 3

I erased my machine and re-installed 12.10. Right before I added all the fonts I know and love, the PDF viewer works.

AFTER... I add the fonts, it stops working. I can only guess that one of the new fonts is overwriting a "core" font Ubuntu needs to make the PDF viewer work.

Anyone know how to restore that font?

I could go through the 900 I install one at a time to see which one is doing it, but that seems like it would take a while.

From: http://ubuntuforums.org/showpost.php?p=12516767&postcount=13

the phrase "core" font made me wonder if Ubuntu had such a thing... it does.

In /usr/share/fonts/truetype

I add my own folder called "myfonts" with 900 .TTF files. When I remove that, the PDF viewer works.... sooo.... I found a folder called "ubuntu-font-family" and copied the contents of that folder to "myfonts" folder overwriting my substitutions with the system originals.

That worked.

The PDF viewer is working normally now. Thank you all.

From http://ubuntuforums.org/showpost.php?p=12516785&postcount=14

In other words, OP has the solution here: [SOLVED] PDF files show no text in 12.10

share|improve this answer
    
I copy my fonts to ~/.fonts and get no problem with overwriting core fonts. –  AliNa Feb 19 '13 at 2:55
    
I posted the answer purely because I got the impression that OP won't follow up. Who knows what fonts OP had :). So, one can't conclude that copying any fonts to ~/.fonts will cause a problem because it didn't for you (and possibly many other people) but did so for OP. –  user25656 Feb 19 '13 at 3:00
1  
:D I just want to introduce an alternative for avoiding such problems but misunderstood! I just recommend to copy fonts to your home directory, not to the root one. –  AliNa Feb 19 '13 at 3:11

How are you able to create a folder in the usr/share/fonts/truetype when it's disabled?

and is there a way to install multiple fonts instead of opening and installing them one at a time?

I only have one pdf file that doesn't show the text while it opens other pdf files with no problem.

share|improve this answer

There are two choices you can make, one is to install Adobe Reader, the other is if you're using Chrome / Chromium, to make that the default .pdf reader.

share|improve this answer
2  
1: That may not address the central issue of why OP is not seeing text in the default PDF Viewer. 2: Chrome, not Chromium, comes with a PDF Viewer "built-in". –  user25656 Feb 17 '13 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.