Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 12.04 on Dell Laptop, after trying on 12.10 + other flavors7u, etc.). Broadcom drivers still not working.

Ethernet connection also nonfunctional, but that's a hardware issue and not the OS's fault. Other forum posts on similar situations are not useful because they require a wired internet connection.

It is a Dell Inspiron e1501. I installed Ubuntu 12.10 via the Windows Installer.

Then installed 12.04 instead, because I heard it was better at handling additional drivers, after I installed 12.04, the addition drivers immediately showed me that my 'Broadcom STA wireless driver' was not activated. I clicked 'Activate' and then nothing happened. Apparently it needs to download the driver, which it can't do, without Internet.


I thought I would just download the drivers on another machine and then try to install them manually.

I went to Broadcom's site and found a Linux driver which I downloaded and transferred to the Ubuntu laptop desktop via SD card. And then I ran 'make' command through the terminal.

Here's some highlights:

root@ubuntu:/home/username/Desktop/wld# make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]:
Entering directory `/usr/src/linux-headers-3.5.0-23-generic'
Wireless Extension is the only possible API for this kernel version
Using Wireless Extension API
Using Wireless Extension API
  CC [M]  /home/username/Desktop/wld/src/wl/sys/wl_linux.o
/home/username/Desktop/wld/src/wl/sys/wl_linux.c:43:24: fatal error: asm/system: No such file or directory
compilation terminated.
make[2]: *** [/home/username/Desktop/wld/src/wl/sys/wl_linux.o] Error 1
make[1]: *** [_module_/home/username/Desktop/wld] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-23-generic'
make: *** [all] Error 2
share|improve this question
1  
Could you please make your question concise and understandable to an international audience? Most of the people here are volunteers. Also, this site works best when there's one question per post. –  user25656 Feb 17 '13 at 18:13
    
@vasa1 There is one question and only one question: How do I install Broadcom proprietary drivers or otherwise get them to work on Ubuntu 12.04 WITHOUT direct internet access via ethernet or extensive knowledge of terminal commands. I don't think that's complicated or international audience exclusive. (Sorry of you don't like the story) –  Jed Oliver Feb 17 '13 at 18:19
add comment

closed as not a real question by Kevin Bowen, Jorge Castro, Eric Carvalho, Alvar, Mitch Jun 22 '13 at 13:54

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Download the following .deb files (choose any mirror you like)

  1. dkms.deb
  2. patch.deb
  3. fakeroot.deb
  4. bcmwl-kernel.deb

transfer the 4 files to a flash drive, and move them to your home directory.

Then double click each file (in the order I listed them). Software center should come up and let you install them.

Once that is done go to the dash and search for "additional drivers" and activate the STA Broadcom driver

share|improve this answer
    
Thanks! will reply when/if that addresses the situation –  Jed Oliver Feb 17 '13 at 19:28
    
Well, I downloaded those .deb files (32-bit, if it matters) an transferred them to the laptop BUT when I go to install them via the software center the "Install" button is grayed out and doesn't allow me to click on it. For anything –  Jed Oliver Feb 17 '13 at 23:49
    
that's weird. I know you don't want to touch the terminal, but you'll just have to enter one line. Open the file manager, navigate to the folder where those deb files are. Right click somewhere in the folder (not on any file) and select "open in terminal". In the terminal type: sudo dpkg -i --force-all *.deb. Press enter, you'll be asked for your password, type it in (you won't see your password or stars as you type, that's normal).Press enter. The packages should install. Once that's done proceed to "additional drivers" in the dash and activate the STA Broadcom driver. –  phipsalabim Feb 17 '13 at 23:59
    
!forget my last comment. I just realized that I linked you to the 12.10 version of these packages. wait for a couple minutes. I'll update the links –  phipsalabim Feb 18 '13 at 0:05
    
updated the links. please delete the other packages you downloaded. Download the correct ones now. transfer them, double click bla bla bla –  phipsalabim Feb 18 '13 at 0:09
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.