Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having just switched to Ubuntu from Mint I tried to install the Chromium browser and Skype. They gave the following errors:

Chromium

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
chromium-browser : Depends: libnss3-1d (>= 3.12.3) but it is not going 
to be installed

Skype:

As soon as I open it with software center it appears

Cannot install libasound2:i386

Any ideas on how to fix either of these?

share|improve this question
    
Run: sudo apt-get install libnss3-1d libasound2:i386 and then try installing them again. –  green7 Feb 17 '13 at 17:37
    
didnt work got this error as soon as I ran that command: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? –  user132952 Feb 17 '13 at 17:42
    
Try logging out and logging back in. Run the command again. –  green7 Feb 17 '13 at 17:44
    
1: Please ask one question at a time. You've asked two. 2: Please incorporate any additional information by editing the question. –  user25656 Feb 17 '13 at 17:45
    
again no effect same error –  user132952 Feb 17 '13 at 17:47
show 1 more comment

1 Answer

Use apt get for chromium, and it will deal with the rest of the missing packages :

Press Ctrl+Alt+T and type sudo apt-get install chromium-browser and press enter.

after that, apt-get will install chromium and all its dependencies...

For skype, most people dont know that its easily available from ubuntu software center. Open another terminal (ctrl+alt+t) and type sudo software-center, to enter the Ubuntu software center as a poweruser (root).

Running software center as root

Then whilst in there, go to the System category of apps, on the left side of the software center interface. Inside, search for skype and it should appear, but without a skype icon though. Open the app synopsis and tick whatever plugins it is linked to, apply changes and then install. :)

share|improve this answer
    
That's a perfect answer! –  Ronshere Oct 10 '13 at 1:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.