Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 on my laptop. Since I couldn't start the installer and only got a "Black screen" I had to start it with the "nomodeset"-parameter.

The installation went fine, after rebooting the system I still had the "Black screen"-issue so I still have to boot the system with "nomodeset".

Now I'm trying to get the right video card drivers installed. The questions are:

How do I find out my exact chip in the first place? (Since "Intel mobile 4 series" doesn't help me a lot here)

How do I install the correct drivers afterwards?

share|improve this question
    
Does anything appear in Additional Drivers/ –  Eliah Kagan Feb 17 '13 at 15:37
    
No it does not. But the problem is solved now. –  Apoc Feb 17 '13 at 16:31
    
Did you solve this problem, or did it seem to just go away by itself? If you solved it, please post an answer explaining how it was solved (answering your own questions is not merely permitted, but encouraged when there is no other answer that does the job). You can even mark your own answer as the accepted answer, 2 days after posting it. This can help others searching for help with the same problem. On the other hand, if it seems to just have gone away by itself, please let us know--we can then close this question as "too localized." –  Eliah Kagan Feb 17 '13 at 16:32
    
The problem didn't solve itself, but since I'm new here I can't answer my own question within 8 hours after asking it =). I'll answer it tomorrow if no one else does. –  Apoc Feb 17 '13 at 17:38
    
Great, thanks! (And I'm glad it's solved.) –  Eliah Kagan Feb 17 '13 at 19:49
add comment

1 Answer

Ok after tinkering a bit more and some digging here I found a solution:

It seems to be a problem with the LCD backlights. The built in intel graphic drivers are actually working, but it simply doesn't turn on the LCD backlight.

A solution can be found here: Intel GMA 4500M screen resolution problem

Instead of booting the system with nomodeset or i915.modeset=0. You have to boot it with: acpi_osi=Linux. This will allow the backlights to be turned on, but you have to do so manually via: sudo setpci -s 00:02.0 F4.B=00.

To automate it you have to edit /etc/rc.local and add the setpci command. The same problem appears after your system comes back from sleep so you have to add the command to the scripts in /etc/pm/sleep.d/.

It did the job for me =)

I hope I can help someone with my research.

Kind regards, Apoc

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.