Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried all fixes on How to fix "ndiswrapper not found"?

On answer 3 Fix suggestion #2 : when sudo make I get

Cannot find kernel build files in /usr/src/linux-headers-3.7.0-7-generic
Please give the path to kernel build directory with
the KBUILD=<path> argument to make

I also have tried uninstalling all ndiswrapper files and re installing. I'm fairly new to Ubuntu. I'm trying to get my Netgear WN311T working.

sudo modprobe ndiswrapper gives me

WARNING: All config files need .conf: /etc/modprobe.d/blacklist, 
it will be ignored in a future release.
FATAL: Module ndiswrapper not found.
share|improve this question
See this solution for Huawei. Something same may be for Netgear. – user224082 Nov 19 '13 at 8:53

Your problem is that "make" is failing, because you do not have the linux kernel headers installed.

Install them with:

sudo apt-get install linux-headers-3.7.0-7-generic
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.