Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I notice when I do:

sudo update-initramfs -u

With the latest kernel release (2.6.38) I get the following warning messages:

update-initramfs: Generating /boot/initrd.img-2.6.38-3-generic-pae
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169

How can I resolve this problem?

Dean Thomson Feb 14 at 4:11 wrote:

Unfortunately, the linux-firmware package isn't for Maverick.

share|improve this question
add comment

4 Answers

take a look at this PPA... it has updated firmware packages:

The missing files can be found in the linux-firmware package

share|improve this answer
    
Unfortunately, the linux-firmware package isn't for Maverick. –  Dean Thomson Feb 14 '11 at 4:11
add comment

First, check if r8169 is a loaded module (lsmod). If it is, use modprobe -r r8169 or rmmod r8169 to temporarily remove it and then install the new kernel or whatever you need to install. Afterward, use modprobe r8169 to re-install the module.

share|improve this answer
add comment

I've just solved the same problem.

I have downloaded linux-firmware package from natty from page https://launchpad.net/ubuntu/+source/linux-firmware and installed it manually:

wget https://launchpad.net/ubuntu/+archive/primary/+files/linux-firmware_1.49_all.deb
sudo dpkg -i linux-firmware_1.49_all.deb 

Then one should call

sudo update-initramfs -u

or, more conveniently

sudo aptitude reinstall linux-image-2.6.38-2.dmz.1-liquorix-686

(place your required kernel package here)

Warning seems to be gone, so all firmwares are on their proper places.

share|improve this answer
add comment

I just fixed the problem by downloading firmware-linux-realtek from Debian.

first, let's make sure you still have the problem:

sudo update-initramfs -u

Now, if you still see the errors get the package:

cd && wget http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-realtek_0.28_all.deb
sudo dpkg -i --force-overwrite firmware-realtek_0.28_all.deb

Let's verify the solution:

sudo update-initramfs -u

If everything goes well, you won't see the messages :)

share|improve this answer
    
This method worked for me on LinuxMint 12 also. Neither the linux-firmware nor linux-firmware-nonfree packages contained the rtl8168f* firmware files, but the debian package does. Note that the current package is firmware-realtek_0.36_all.deb and the 0.28_all package has been removed (though there is a 0.28 package with squeeze in the name). –  Matthew Jun 29 '12 at 20:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.