Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

From version 8 onwards Windows Phone supports MTP (media transfer protocol) to transfer audio and I thought I could use Rhythmbox to upload music onto my device.

Thing is Rhythmbox doesn't display the device under Devices pane (there's no Device pane for that matter).

I searched other questions here and tried out installing mtp-tools, mtpfs and also tried gMTP, which doesn't seem to detect the device as a portable player.

I see that the device's icon looks like a Camera in dash bar and when I see the address location, it shows gphoto2://[usb:002,013]/, which makes me doubt that it's detected as a camera or as a mass storage device. /.gvfs/gphoto2 mount on usb%3A002,003 is where the actual mount is. What do I do to fix this?

I tried creating .is_audio_player too.

share|improve this question

I was just reading this article:

"You can navigate to your phone's Music folder (or the Music folder on your phone's SD card, if it has one), and then drag files to it from your PC."

which to me makes it sound like you can (outside of rythmbox) open the Music folder on the device and copy files directly there. The simple solution might be to just to open your PC's music folder, select all, and copy the music into the device's music folder.

Does that work for you? This doesn't work at all with my WP7, but I was thinking of an upgrade to keep my trifecta going -- Ubuntu Dekstop, Android Tablet, Windows Phone :) If that doesn't work I'm hoping there's good cloud storage.

share|improve this answer
Of course, directly copying music to the phone's music folder was my obvious first method. Didn't work out :( – legends2k Mar 6 '13 at 19:04
With Windows Mobile devices, you could navigate onto them as if they were hard drives, but you had to have windows mobile device center (or activesync) installed. I'll be that's the case with Windows 8. Thanks. – Vic Boudolf Mar 6 '13 at 23:03
But how do you install ActiveSync on Ubuntu? – legends2k Mar 7 '13 at 1:27
I don't think you can. My guess is that it is too integrated with Windows to be something that would work with Wine. It would be quite a trick. For now I'll be using a Virtual Machine with Windows running. – Vic Boudolf Mar 7 '13 at 13:45
Something like that is what I do too; but would be something worth trying out. – legends2k Mar 7 '13 at 19:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.