Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

my Ubuntu does not want to boot up from an external usb drive. It only happens for my stationary PC though, while it runs nicely for my asus laptop.

Here goes the boot-repair:

If matters, the story of my problem solving is as follows:

I have a 120 SSD drive (only) with windows and some games installed on my PC, and have really no option to put a wubi installation next to it (no space obviously). So I decided to put ubuntu on my external drive (500gb in size), using wubi.

It worked nicely, but after few days it didn't boot and dropped to BusyBox shell. For wrong reasons I decided I cannot fix this (maybe I could, do not matter now I guess), and tried to reinstall ubuntu once again.

I've read somewhere that wubi is supposed to install ubuntu inside windows installation, and if I want to put my ubuntu on the external drive, it is better to do it from liveUSB. So I installed it like three or four times, each time following a different tutorial and getting same result.

No booting from PC.

Once it stated that it lacks boot manager, whatever that might mean.

Tried to use boot-repair at this point, it processed for ages and stated that all should be fine now, but it ain't.

I guess that my system is now a real mess with grub configured for non-existing ubuntu instalation and external drive split into three non-usable partitions. And I have no much idea how to solve it anymore.

I'd be glad for any help, or at least a link to solid guide on how to get what I want. I am veteran on installing ubuntu now, though I'd like to install it working at least once.

Cheers, Magic

share|improve this question

at the very end of the file you uploaded it says:

Boot successfully repaired.

You can now reboot your computer. Please do not forget to make your BIOS boot on the removable disk!

A broken Wubi has been detected. Please fix it this way:

First uninstall/remove Wubi. Then change BIOS settings to boot from your external Hard drive. By default your PC doesn't look for an OS on external disks.

share|improve this answer

copy all the files you want off of the drive (copy them back over after this guide has finished)

urm with the external mounted, open g parted, then select the drive in the top left MAKE SURE ITS THE RIGHT SIZE AND THE RIGHT DRIVE

delete all the partitions so it is unallocated

then follow this guide i mentioned to another post...

what your asking is to be able to run ubuntu with (saving files permenantly, as a full desktop) while still being able to use part of the hard drive to save files:)

basically take everything important off it and somewhere else

Open Gparted and delete all partitions

place your ubuntu disc in (or make one) install ubuntu (ON YOUR PORTABLE HARD DRIVE) but when it asks to use the entire space hit no, as what space you leave will be the space windows sees


open your bios and set the boot order to check for usb before the hard drives in the computer (note if your computer ever fails to boot unplug all usbs)

you should now be able to boot off the portable when its plugged in and your normal os when its not

now open gparted and go to the partable

in the unallocated space left after the install create a partition out of all the space (NTFS and primary) windows will only see the ntfs partition

boot off the portable and place a shortcut(link) in your desktop to the ntfs partition,

if you want to boot your ubuntu portable off any computer just go into the bios and select boot menu

select boot from usb:)

Hope it helps, if not feel free to comment or contact meh

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.