Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I installed Ubuntu 12.10 yesterday and today when I try to login my desktop interface doesn't load. I only see my wallpaper and my one icon (steam) on it, but I don't see left/top taskbars. Please help.

my computer specs:

proc: Intel Core 2 Duo E8400 3GHz  
graphics: ATI HD 6850  
mainboard: Asus P5K PRO  
RAM: 6GB  
share|improve this question
    
Can you add a little more info, especially regarding your graphics card and whether you installed drivers for it –  Chris Carter Feb 17 '13 at 11:52
    
Yes, i tried installing some graphic drivers in order to get better performance in Team Fortress 2. I wrote the details on Steam Forums –  Kossak Feb 17 '13 at 12:26
    
I will post my hardware here too: ATI HD 6850 Intel Core 2 Duo E8400 3GHz 6 GB of RAM Asus P5K PRO –  Kossak Feb 17 '13 at 12:26
    
I am struggling to find a definitive answer on Ask but there are several including this askubuntu.com/questions/202857/… . The key seems to be sudo apt-get install linux-headers-generic –  Chris Carter Feb 17 '13 at 12:43
    
Thank you Chris, this solved my problem with installing ATI driver. I also found solution for invisible taskbar in Unity 3D, thank you all for help. This is the magic that solved my problem (that Unity 3D desktop wasn't showing up properly): I wrote these commands in terminal, one at a time: "sudo apt-get purge fglrx lightdm" "sudo apt-get install lightdm ubuntu-desktop" –  Kossak Feb 17 '13 at 15:38
show 1 more comment

marked as duplicate by Javier Rivera, belacqua, Seth, ajmitch, hhlp Feb 21 '13 at 9:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

Try to select at the loginscreen Unity 2D (this is done via the little 'radar-icon' nearby your login name (the one were you type in your name and password)

If this loads correct, you can adjust some things so Unity 3D loads properly. I suspect the Steam-program got a little bit in the way with something. (This you have to test over and over again)

If Unity 2D doesn't load:

Can you start up in recovery mode ?

  • To achieve this simply open up Grub (after Bios-screen press and hold SHIFT) and select the recovery modus. From there on you can try to initialise Unity again.

We need a bit more information, I see you've installed Steam is that program shut down correctly before you quited Ubuntu ?

Apparently it's clear that Unity doesn't load fully; so if tweaks were made (e.g. CCSM used) it could be they are in the way of things.

share|improve this answer
    
see also Chris Carter's comment please –  Joris Donders Feb 17 '13 at 11:58
    
There is no Unity/Ubuntu 2d with 12.10. 12.04 was the last to have it. –  Chris Carter Feb 17 '13 at 12:17
    
Yea i don't see any "unity". I installed gnome (according to Michael post) but want the default one (it's called "ubuntu" too i think) cause i like it more. Earlier i tried to install graphic drivers, i wrote the details on Steam forums –  Kossak Feb 17 '13 at 12:32
add comment

I was having the same issue earlier and never quite fixed it. I did, however, simply install a different GUI to replace the default one which kept disappearing on me.

So just open up the terminal after you've logged in and the GUI still hasn't appeared and type in sudo apt-get install gnome-shell

Once it's done, reboot and chose one of the GNOME settings in the dropdown menu instead of Ubuntu when you log in.

share|improve this answer
add comment
up vote 0 down vote accepted

Write in console these commands, one at a time:

sudo apt-get purge fglrx lightdm
sudo apt-get install lightdm ubuntu-desktop

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.