Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I love Unity so far. But since last update (of what? I don't know. It happened after i restarted my PC), Navigation between the 4 desktops has changed. I can still click on an app in the launcher to move to the desktop where the app is located (which i love) - but when arrived on this other desktop - Unity shows me a 200px*100px map of all desktops for 1 sec... which is pure visual pollution if you want my opinion.

Can I prevent Unity from displaying this 'map' when i slide from one desktop to another using the launcher icons?

Also, I'm searching for a list of key shortcuts to navigate between desktops if it exists...

Thank you very much in advance. DenisefromFrance

share|improve this question
up vote 7 down vote accepted

Disabling Previews

You can do it using Compiz Config Settings Manager.

  • Install Compiz Config Settings Manager
    • Open a terminal (Ctrl+Alt+T).
    • Run the following command:
sudo apt-get install compizconfig-settings-manager
  • Changing Settings
    • Open Compiz Config Settings Manager by searching the same in the dash or from the terminal using ccsm command.
    • Goto Desktop > Desktop Wall, as shown in the screenshot below.

enter image description here

  • Uncheck Show Viewport Switcher Preview and Show Live Viewport Previews, as shown in the screenshot below.

enter image description here

  • Close Compiz Config Settings Manager.

To revert back to the default settings, just check the two checkboxes again.

Shortcuts for navigating

To navigate around the workspaces, the controls are:

  • Ctrl+Alt+Left Arrow: Switch to the left workspace
  • Ctrl+Alt+Right Arrow: Switch to the right workspace
  • Ctrl+Alt+Up Arrow: Switch to the upper workspace
  • Ctrl+Alt+Down Arrow: Switch to the workspace below

You can see the full list of shortcuts by holding the Windows key (also shown in the screenshot below).

enter image description here

share|improve this answer
Thank you so much Green7 for this so complete answer!!! Have a great day! – Denise Feb 17 '13 at 11:29
You can accept the answer if you find it useful. :) – green Feb 17 '13 at 12:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.