Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop's battery performance is awful. I can get about an hour and a half out of it, so I've been looking for some ways to boost the power efficiency of my laptop.

I saw the tip to enable this:

echo 1 > /sys/devices/system/cpu/sched_mc_power_savings

But it does not exist on this installation. What happened to it?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

This seems to be part of laptop_mode (Ubuntu man page): sudo apt-get install laptop-mode-tools

more /etc/laptop-mode/conf.d/sched-mc-power-savings.conf and on the bottom it says:

# Control multi-core power-saving tunables for the process scheduler?
# Set to 0 to disable
CONTROL_SCHED_MC_POWER_SAVINGS="auto"
share|improve this answer
add comment

Same for me! I have read that for somebody recompiling the kernel with the right processor family (core 2 instead of standard) resolved that problem (see http://www.linux-solved.com/post/Solved-Missing-sys-devices-system-cpu-sched-mc-power-savings-61510.html). However not for me! So my machine still exhausts 5Watts more than on other distris with a running scheduler.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.