Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to update my graphics driver to properly use XBMC, and suddently the taskbar // unity (not quite sure its called) the side bar & top bar vanished after a restart, As im quite new to the Linux OS.

It is currently showing that my current graphics driver is: "Vesa: GT218 Board - 06910002" which is completly unknow for me, it appeared after the restart.

Note: - AMD Athlon(tm) II x2 215 Processor x2 - Nvida graphics card

share|improve this question
1  
Welcome to Ask Ubuntu! Since you seem to have found the answer, please post it as an answer to your own question. Or, if an existing answer is the solution, you can accept that. (When there is no other satisfactory answer and you've found the answer, we encourage self-answers.) 2 days after posting it, you can accept your own answer (by clicking the gray check mark to the left of it). This will make clear that your problem is solved, and also help others searching for solutions to this or similar problems. –  Eliah Kagan Feb 17 '13 at 0:33
add comment

2 Answers

I believe you tried to update proprietary driver. So, you can remove proprietary drivers (return to free nouveau). Try this terminal commands:

sudo stop lightdm
sudo apt-get purge nvidia*
sudo apt-get install xserver-xorg-video-nouveau
sudo reboot

Now, you should have all working with free drivers. You can try to install proprietary driver again.

share|improve this answer
    
I tried using the commands you linked, but after the reboot, the unity was still missing, however the "flickering" i failed to mention in my previous post was gone It now shows that i do not have an active graphic driver tho. –  user132732 Feb 16 '13 at 23:22
    
You have 2 options right now, 1) Move xorg.conf - sudo mv /etc/x11/xorg.conf /etc/x11/xorg.conf.bak && sudo reboot ;; 2) Try to install nvidia proprietary from ubuntu repository - sudo apt-get install nvidia-current && sudo reboot –  zatloukal-frantisek Feb 16 '13 at 23:28
    
I couldnt get the 1) option to work, but however after doing the 2) option the startup went into some sort of "recovery" mode, but the Unity is still missing –  user132732 Feb 16 '13 at 23:40
add comment

I know that AMD drivers need the linux-headers-generic package to work, and I suspect that the issue might be the same with nvidia.

sudo apt-get install linux-headers-generic

And then try to install the driver.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.