Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alright so my computer is 64-bit and I only want to use Linux to install Steam, play Team Fortress 2 and get that penguin item but It's not working out for me. The version of Ubuntu I installed was the "Wubi.exe" which let's me use it along with Windows. But when I get it up and download the Steam .deb file, it tells me "Wrong Architecture 'i386'". What do I have to do to run Ubuntu alongside windows without using a CD/USB stick?

share|improve this question
Similar question: How can I install Steam? –  minerz029 Mar 8 '14 at 11:22

4 Answers 4

Open the terminal and type:

sudo dpkg --add-architecture i386
sudo apt-get update

Try installing it after doing that.

For future reference look: https://wiki.ubuntu.com/MultiarchSpec & https://help.ubuntu.com/community/MultiArch

share|improve this answer
still doesnt work for me –  user132730 Feb 16 '13 at 23:08
It worked fine here when I've ran into the problem. (And It's the way many people fixed it) –  Blastcore Feb 16 '13 at 23:18
@user132730 after doing that run sudo apt-get install ia32-libs as has been suggested by lordqwerty. –  handuel Apr 7 '13 at 14:41
recent versions of Ubuntu supports multiarch natively (both precise and trusty), you just need to apt-get install steam. –  Giovanni Toraldo Jun 7 '14 at 10:39

Try installing the ia32 libs by opening up a terminal and entering the following:

sudo apt-get install ia32-libs

Once that has run and installed, then use terminal to install Steam for you. Run the following in terminal:

sudo apt-get install steam

Now you will have Steam installed and you should be able to launch it as expected.

share|improve this answer
This answer is the second part of the solution. First you need to add the i386 architecture... see bugs.launchpad.net/wubi/+bug/1093819 and bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294/… –  bcbc Feb 17 '13 at 1:28
ia32-libs should in theory increase stability, but yeh :) –  lordqwerty Feb 17 '13 at 10:55

Hit Alt+Ctrl+T to open the terminal and run following commands:

sudo dpkg --add-architecture i386
sudo apt-get update
share|improve this answer

Talk of i386 or ia32-libs doesn't work for 14.04. When I try the later, I receive the following output: However the following packages replace it: lib32z1 lib32ncurses5 lib32bz2-1.0

As such, this solution works for me. Alt+Ctrl+T to open the terminal and run following commands:

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0
sudo apt-get install steam

Steam works as expected from here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.