Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have paired my nokia 3110c via bt on my pc, I can receive a file from my pc to the phone, but I can not browse the contents of phone from my computer. Here is the error message

Error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Please select another viewer and try again.

How can I transfer contents from my phone to my computer?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I have solved the problem, or rather say found the reason behind the problem.

The main reason behind this problem was battery level,

(Guess) if the battery level reaches below some point, the device doesn't recognize or process the request sent by the machine and can not send proper reply to machine. That can be the reason why we can not access the file system.

We have also tried one samsung phone, and a sony Erickson phone with low battery (in each case more than 60% battery is drained) and got same result.

share|improve this answer

Most likely you will need to debug obex-data-server.

You can install qt4-dev-tools, launch qdbusviewer and search for "obex" in the session bus. If it doesn't find anything, launch obex-data-server from terminal. Then you will see org.openobex point and will be able to play with some of its methods.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.