Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a debian/ubuntu embedded boards that I connect them via an ad-hoc network with the following settings

board:~# cat /etc/network/interfaces
auto wlan0
iface wlan0 inet static
        address 10.0.0.2
        netmask 255.255.255.0
        wpa-driver nl80211
        wpa-conf /etc/wpa_supplicant.conf

board:~# cat /etc/wpa_supplicant.conf
# IBSS/ad-hoc network with WPA-None/TKIP.
ctrl_interface=/var/run/wpa_supplicant
ap_scan=1

network={
        ssid="adhoc_test"
        mode=1
        frequency=2412
        proto=WPA
        key_mgmt=WPA-NONE
        pairwise=NONE
        group=TKIP
        psk="abcdefgh"
        bssid=F8:D1:11:52:0C:4E
}

These configurations creates an ad-hoc wlan, however, the nodes often gets different cell ID so that they cannot communicate with each other. To prevent it I added bssid=F8:D1:11:52:0C:4E line, however, no node get this predefined cell ID when they get the cell ID.

My question is that how can I prevent nodes to get different cell IDs? why bssid line does not work in the ad-hoc mode?

P.S. I tried these settings on ubuntu and debian dist. that have 3.2 and 3.4 kernels. wpa_supplicant versions that I used were 0.7, 1.0, and 2.0 all did not work. For the chipset, I am using Atheros AR9271 chipset for the wifi module.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

the problem was that previous versions of wpa_supplicant does not support the bssid, installing wpa_Supplicant 2.0 solved the problem!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.