Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have Win7 and ubuntu partition in my laptotp. I downloaded Steam .deb package. I tried to install it by doubleclicking it, but it said: Internal Error The file “/home/djokosihono/Desktop/steam_latest.deb” could not be opened. And when I try to install it using Terminal, it said: dpkg: error processing steam_latest.deb (--install): package architecture (i386) does not match system (amd64) Errors were encountered while processing: steam_latest.deb

It also happened when I try to install Google Chrome.

Is there any solutions for this? Thanks in advance.

share|improve this question

marked as duplicate by qbi, Eric Carvalho, Seth, hhlp, Luis Alvarado Feb 18 '13 at 16:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please use this answer to intall steam –  efthialex Feb 16 '13 at 10:59
add comment

2 Answers 2

up vote 2 down vote accepted

It's very good that you included the error message (dpkg: error processing steam_latest.deb (--install): package architecture (i386) does not match system (amd64) Errors were encountered while processing: steam_latest.deb). From this the problem is fairly clear. You have a 64 bit processor but the package ist for 32 bit. So you need a different package.

But as Steam is now in the Ubuntu Software Center, that would be the way to go. In linux you never download programs manually. If it's not in the Ubuntu Software Center, you can almost always find a repository for ubuntu where you can get what you want.

share|improve this answer
    
Thanks for helping me! –  Dimas Krissanto Rahmadi Feb 16 '13 at 11:07
add comment

You should either download the 64bit version of the deb package or just install Steam from the Ubuntu Software-Center.

share|improve this answer
    
But when I try to install Steam from the software center, it says: The following packages have unmet dependencies: steam64: Depends: steam (= 1.0.0.27ubuntu1) but it is not going to be installed. Is there any solutions? –  Dimas Krissanto Rahmadi Feb 16 '13 at 12:00
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.