Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I go into Synaptic and try to install the handbrake-gtk, after it gives me the list of all the other packages it has to install, I get this message:

The following packages have unresolved dependencies. Make sure that all required repositories are added and enabled in the 'Repositories' option under 'Settings'

handbrake-gtk:i386: Depends: libwebkitgtk-1.0-0 but it is not going to be installed

I tried installing in the terminal but that wouldn't work either, I think for the same reason.

Now using the pages http://www.ubuntuupdates.org/ppa/webkit_team?dist=precise and http://www.ubuntuupdates.org/package/webkit_team/precise/main/base/libwebkitgtk-1.0-0 and the terminal I supposedly added and install the libwebkitgtk-1.0.0 package, but whenever I go back into Synaptic and try to install Handbrake I still get the same error message.

Thanks in advance.

share|improve this question
    
Take a look at This –  Mitch Feb 16 '13 at 8:53
    
No sorry, still not working. Compiling from source was working right up until sudo make when, after about 5 minutes of code just streaming past me in the terminal, I got an error message. I tried to go on to sudo make install but I just got a similar error message. –  schtocker Feb 16 '13 at 9:45
    
Try installing from USC –  Mitch Feb 16 '13 at 10:46
    
Hmmm, I suspect that you have the 64bit version of libwebkit installed but handbrake wants the 32bit version. Maybe try to manually install libwebkitgtk-1.0-0:i386. (In synaptic or using apt-get.) –  Béné Feb 16 '13 at 11:06
    
Mitch - Nope, I'm getting package not found –  schtocker Feb 16 '13 at 13:41

1 Answer 1

up vote 4 down vote accepted

What I did was the following:

Since using any of the 2 PPAs in: https://launchpad.net/~stebbins was actually not working for 64 bit systems, I just went and downloaded the package. In my case I did the following:

  1. Used the Handbrake Snapshot PPA found here

  2. Click on View Package Details

    enter image description here

  3. Select the Ubuntu version you are using, then click on Filter

    enter image description here

  4. Click on the most updated Package available there. In this case there is only one. It should expand to show everything related to that package.

    enter image description here

  5. Go down until you get to where all packages for each Architecture are shown. Download the ones that are for your version. In this case, the ones that say amd64 are for 64 Bit systems.

    enter image description here

  6. After downloading both (The CLI and GUI Versions), simply double click them. Software Center will take care of the rest.

The end result should be something like this:

enter image description here

This is what I did on 12.04, 12.10 and even on 13.04 using the 12.10 package. All cases with 64 Bit PCs.

share|improve this answer
    
This worked perfectly, thank you! –  schtocker Feb 21 '13 at 22:38
    
@schtocker the only thing am sorry about is that the borders of the images are the same as the background color of the post. In my monitor it looks kind of strange to see Text, then the image, then Text and so on. –  Luis Alvarado Feb 21 '13 at 23:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.