Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried to install Piklab into my Ubuntu 12.04 LTS 32-bit, and I tried to use this and this method. None of them really worked. During cmake ., my shell displays me lots of messages, but I think this is the main one:

-- Could NOT find ncurses (missing NCURSES_LIBRARY NCURSES_INCLUDE_DIR)

What can I do to solve this situation? I've tried to install the most recent version, got from SourceForge.

share|improve this question
    
You can upload all the output in paste.ubuntu.com and then link it into your question. About your line, you have to install the ncurses library, to do so enter in terminal: sudo apt-get install libncurses5-dev –  Lucio Feb 16 '13 at 4:33
    
It worked perfectly! Kind of a silly detail that I wasn't thinking about it. Thanks @Lucio :) –  CesarUR Feb 16 '13 at 21:37
    
If you don't care I will transfer my comment into an answer, where you can mark as accepted and upvote it. So future users will know how to solve the problem. –  Lucio Feb 17 '13 at 1:30
    
Sure, no problem at all! You helped me, so I think you deserve the credits ;) –  CesarUR Feb 17 '13 at 5:37

2 Answers 2

up vote 1 down vote accepted

You are right, the main information is that line. It is telling you that your system doesn't have the ncurses library.

To install it you have to enter the next command in a terminal:

sudo apt-get install libncurses5-dev
share|improve this answer

You get that error message because you haven't installed a dependency, which compiling this software requires.

Their wiki mentions these dependencies that you need to have installed:

libusb-dev libreadline-dev libqt4-dev kdelibs5-dev

You can install them through running sudo apt-get install [package names] in the terminal.

share|improve this answer
    
Unfortunately, it's not the case. I've downloaded several packages from both links that I tagged before, including those ones that you recommended me... the same message keeps coming back. Maybe this information is important: I'm running my Ubuntu over VMWare Player. –  CesarUR Feb 16 '13 at 5:27
    
Did you every try to install ncurses through sudo apt-get install libncurses5-dev as Lucio suggested? –  Daniel Jonsson Feb 16 '13 at 8:38
    
It worked perfectly! Kind of a silly detail that I wasn't thinking about it. Thanks @daniel :) –  CesarUR Feb 16 '13 at 21:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.