Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I frequently upgrade the desktop of my daughter (using ubuntu 12.04.1) through the official processes,but in the latest attempt the computer is asking for a root (or super user) password. In the past I always used the administrator password. This one is now no longer accepted. Can't also not unlock the administrators account in users accounts. Every that used the computer claims not to have entered a root password. Nobody knows another password than the administrator password? Something must have gone wrong somewhere.

How do I disable the root password? I have tried some advices from this site, such as sudo passwd -dl root, but the computer replies that the administrator is not in the sudoers file after entering the administrators password.

What can I do to remove or get around the root password?

share|improve this question
Have you tried adding the user to the sudoers file? – Lucio Feb 16 '13 at 4:46
  1. Reboot the computer and stay in the grub menu.
  2. Select the default entry and press "e".
  3. Add to the kernel line at the end " single" (if it doesn't work try with 1).
  4. Press "b" to boot with the modified parameters. You will be prompted with a console, this is a passwordless root console.

  5. You can change the root password with passwd and you will not be asked for the old password.

  6. After that, reboot and in terminal as root, add yourself to sudoers (because it seems you have removed yourself from the list).
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.