Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have dual-booted Ubuntu 12.04 on my Macbook Pro 9,2 without any problems after I have managed to boot into Ubuntu. However, to do that I must use super grub disk. I have a dual boot system, so I thought it would be inadvisable to install grub directly to /dev/sda, and thus installed it to /dev/sda6 (I have a shared partition in between Mac and Ubuntu to transfer files). I am using rEFIt, and whenever I try to boot into Ubuntu from rEFIt it drops me to the grub rescue prompt. I know that my grub.cfg is fine, because I can use it from super grub. Also, before it drops me to the grub rescue prompt, it tells me that it can't find the partition (I don't know which one). I have synced my partition tables using rEFIt, and updated grub with update-grub, but to no avail. Does anyone have any ideas for what could be wrong and how I could fix it?

share|improve this question
up vote 1 down vote accepted

I recommend you try an EFI-mode boot of Ubuntu rather than the BIOS-mode boot you're trying now. You can find instructions on how to do the conversion in the "Fixing the Installation" section of my EFI-Booting Ubuntu on a Mac Web page. That page assumes use of rEFInd, which is my updated fork of rEFIt, but the procedure will work with rEFIt, too, provided you're willing to boot through GRUB. If you stick with rEFIt, you can skip steps 8-11. If you also have Windows installed, you must skip steps 1-7.

One caveat: Although booting Macs to Linux in EFI mode works fine on most systems, it does pose problems on some systems, typically because of hardware that fails to initialize properly. Therefore, if you have problems, you may need to restore the BIOS-boot configuration by reversing the procedure.

share|improve this answer
Thanks, that worked, I just installed grub-efi to /boot/efi/efi/ubuntu, and rEFIt picked it up, and I was able to boot into ubuntu, through grub. I might look at rEFInd to boot directly to ubuntu, but I'm just happy it works now. – cheshircat Feb 18 '13 at 20:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.