Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had to install Ubuntu 4 times to realise what was happening.

The problem is basically that following this few steps Ubuntu gets frozen on loading screen (before login).

  1. Install Ubuntu 12.04.2
  2. Update software
  3. Install Steam from

After this I can perfectly download and play any available game, but the next time I reboot my system it will not load =(

Anyone with the same problem or some suggestion? Thanks

share|improve this question
Hello loxiw and welcome on Ask Ubuntu ! Try doing steps 1 and 2, then reboot. See if the not-loading is already occurring without Steam or not. Furthermore, could you be a little more precise about that "not loading" ? – Agmenor Feb 16 '13 at 0:51
If it's a bug in Steam contact Valve and tell them as bugs are off-topic here. – Uri Herrera Feb 16 '13 at 0:54
I can confirm that it loads before the first two steps, and it gets frozen between selecting Ubuntu in grub and the login (account selection), in the screen with Ubuntu's logo. – loxiw Feb 16 '13 at 0:57
@UriHerrera Reporting a bug upstream in Steam is not going to fix a broken Ubuntu system. A bug may have caused the problem here, but the problem is now separate from the bug, and we're probably the best people to fix it. loxiw: You should report this as a bug, though, unless you have reason to believe it has some other cause (for example, if you installed other software or made configuration changes unrelated to Steam). When you see the splash screen (with the Ubuntu logo, where it's freezing), press Escape. This should reveal the text "behind" the splash. What does it say? – Eliah Kagan Feb 16 '13 at 1:16

It seems steam's repo has not been updated to support 12.04.2 yet. as you can see in this screenshot steam tries to downgrade a crapload of important packages:

share|improve this answer
That's the package from the Software Center or from steam's website? – loxiw Feb 16 '13 at 12:38

If the problem is downgraded packages, then it can probably be solved like this:

  1. Press Ctrl+Alt+F1. Now you can log in non-graphically. As you enter your password, you won't see anything happening on the screen--that's normal.

  2. Run sudo apt-get remove steam and sudo apt-get remove steam64. (I've listed them as separate commands in case for any reason APT doesn't know about either package--the other will still be uninstalled.)

  3. Update packages back to their previous state by running:

    sudo apt-get update
    sudo apt-get -y upgrade
    sudo apt-get dist-upgrade
  4. Reboot the machine: sudo reboot

Your system will likely be fixed. If it is not, or if you are unable to complete these steps (for example, if Ctrl+Alt+F1 doesn't do anything), please update your question with more information (and also with the information I requested here).

share|improve this answer
Nop, still doesn't load, thank you anyway :) – loxiw Feb 16 '13 at 12:48
@loxiw Were you able to perform all those steps, and it didn't work? Or were you not able to run them? Were there any error messages? – Eliah Kagan Feb 16 '13 at 12:52
By the way by clicking Esc in that screen it takes me to the login (by console) and all seems fine... I'm a really noob in Linux so I don't know if something is wrong there. – loxiw Feb 16 '13 at 12:56
I did all the steps without errors, but still doesn't load... – loxiw Feb 16 '13 at 12:57
Pressing F2 is even worse, the screen frozens before even loading Ubuntu's logo XD. This is the screen – loxiw Feb 16 '13 at 14:44

I am having somewhat of the same problem. My 12.04 isn't working after installing steam FROM their website. It worked fine and I could sign in a message people, but when I rebooted - gnome would not start. I could change terminals and log in that way, but gnome would not start. Please help!

share|improve this answer

I believe I have a solution. I had what seems to be the same problem--on a fully updated clean installation of Ubuntu 12.04.2 64-bit with the AMD 13.1 driver, I installed Steam and rebooted, and the system did not load.

At the Steam Community website, I found this thread by JohnV:

"Package dependencies cannot be resolved" workaround

I was able to reproduce one of the "Package dependencies cannot be resolved" issues today. It happens if you install the Ubuntu 12.04.2 x64 build and then search and install Steam from the Ubuntu Software Center. We are looking into this now.


Sorry we did not catch this earlier, but I think the 12.04.2 just came out yesterday so we did not test it.

d2kx posted an answer:

@Valve: If you simply update Ubuntu 12.04/12.04.1, there are no chances and Steam will work fine. The new Ubuntu 12.04.2 includes a backported graphics/kernel stack from Ubuntu 12.10 so it works on newer hardware. It uses packages that end with -lts-quantal (e.g. xserver-xorg-core-lts-quantal). You need to adapt the dependencies of the Steam .deb to reflect those changes and push the new version on the website and the Ubuntu Software Center.

share|improve this answer
Understood, I suppose its a matter of time then :) – loxiw Feb 16 '13 at 21:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.