Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

(12.10, both KDE and xfce4)

For some reason, Firefox has stopped working when launched from the window manager's launcher. The program runs, but nothing happens. If I try again, I get an error popup that tells me another instance of Firefox is already running, which is true according to ps.

If I strace the process, it's stuck on a FUTEX_WAIT_PRIVATE system call. Does anybody know how to make that stop happening? (I found an old blog post that claimed it has something to do with assistive technologies being enabled, but on my system they're not as far as I can tell.)

Oh, and I can start Firefox successfully by launching it from an xterm window.

share|improve this question

I have this very same issue. When I start my machine and log into Unity, one of the first things I will launch is Firefox. The icon in the Unity bar flashes a few times and then nothing.

I go to into System Monitor and find 2 Firefox processes that is a zombie and other sleeping. If I do a 'strace -p ' on the sleeping process, it shows it is stuck on FUTEX_WAIT_PRIVATE.

This didn't occur when I was on 12.04, just since updating to 12.10. I've also seen the suggestion to disable the Firefox add-ons for Unity Desktop, Unity Websites, Global Menu Bar Integation, and Ubuntu Firefox Mods. I've done this, but get the same result.

Now, if while in System Monitor I kill the sleeping process, I can try to relaunch. Typically the 2nd launch works fine. But the first never does.

I'm thinking this still has has something to do with Unity, even with Unity integration add-ons disabled, because if I use Gnome or XFCE for desktop management...then Firefox launches fine the first time, or any time.

share|improve this answer
It happens to me from both KDE and xfce4, so I don't think it's a Unity thing. – Pointy Feb 26 '13 at 23:11

you can terminate the sleeping process by KILL signal

killall -SIGNAME process-name


kill -9 PIDnumber

or reach that from System monitor, guess by right click? (have xubuntu)

share|improve this answer
Yes, I can terminate the process, but that doesn't help much. It always hangs when launched from the start menu. I have to launch it from an xterm window, which always works. – Pointy Mar 26 '13 at 17:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.