Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

With additional drivers installed and a general updated:
- on boot, stuck at purple start up screen with five orange dots and ubuntu logo.
- Hard drive light turns off
- ctrl alt F1 -F6 are all unresponsive.
- ctrl alt del is the only repsonsive command (restart)

I then attempted without additional drivers installed. After general update and reboot:
- screen goes idle during boot
- ctrl alt F1 -F6 are all unresponsive
- ctrl alt del is the only repsonsive command (restart) upon being pressed, the screen stops being idle for a second or so in which I see the shutting down screen then it restarts the computer.

If I boot in safety mode I can get into a terminal based version with no GUI

I am currently trying 12.10 instead to see if it works.

It does work, except it doesn't run steam, but it actually can boot more than once, now I just have to pick which faulty version of ubuntu I go with, so which is easier to fix

Computer Specs:
Dell optiplex 755
Core2Duo 2.33 GHz
3 sata hard drives (direct connection to motherboard)
(unused) wirelesscard in PCI slot
ATI Radeon HD 5570 PCI slot 2

share|improve this question
Malanok, if an answer solved your problem, don't hesitate to upvote it and to mark it as accepted ! :-) – Agmenor Feb 17 '13 at 16:45

OP posted:

  1. boot in safemode
  2. at the TTY terminal that appears follow Is my ATI graphics card supported in Ubuntu? (found and suggested by Agmenor (go thank him if this works for you ))
  3. reboot (command is sudo reboot)
  4. if works, yay, if not, continue
  5. press alt and F5, then try alt F6 etc until the screen changes to a status report like thing, if it says "checking battery" then look at and follow the instructions there
  6. reboot
share|improve this answer

Normally, to update your driver I would advice to use the "Additional Drivers" tab in the "Software Sources" app. However that did not work for you apparently.

If you get only medium performance with your graphics card while playing, you can try to update your driver anyway. This page gives a very well detailed explanation on how to do that properly : Is my ATI graphics card supported in Ubuntu?. This requires the use of the command line.

share|improve this answer
I tried without using the drivers suggested, and ran a check to see if everything was up to date. I had the same problem occur, except this time, the screen received no video and shut off. When I pressed control alt and delete the screen flicked on for half a second showing ubuntu shutting down. I am using a dell optiplex 755 with GB of ram, the graphics card mentioned above and 3 hard drives, each off of sata from the motherboard... I don't know what else to do... – Malanok Feb 16 '13 at 0:16
So even without additional drivers, you cannot get past the orange dots ? Have I understood that well ? If yes, try to follow the instructions I linked to, in a TTY terminal (Ctrl+Alt+F1). – Agmenor Feb 16 '13 at 0:23
with the additional drivers, I can see the orange dots, but cannot get into TTY terminal or any further, the only keyboard command that works is control alt delete, restart. Without the additional drivers, it doesn't boot and the screen goes idle, the only command which brings it out of idle is, again, restart, control alt and delete. I am trying 12.10, I tried that yesterday and it worked, but 32 bit programs weren't working (and steam64 bit needs 32 bit to be working for some reason) – Malanok Feb 16 '13 at 0:28
I will personally be of little help from now on. :-( What I suggest is that you edit your question to summarize what you did and what doesn't work. Try to make your text twice as shorter to make reading easier. – Agmenor Feb 16 '13 at 0:32
Thank you for your help so far, you offered some good suggestions, I will have to look at that topic once I get ubuntu with general updates working x.x; – Malanok Feb 16 '13 at 0:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.